View Single Post
  #51  
Old 06-29-2012, 12:09 PM
Wabbajack Wabbajack is offline
Officially Welcomed to the 'Fest
Location: Colorado High Country
 
Join Date: Mar 2012
Posts: 405
Mein Auto: 2013 X3 35i
Well, I stopped in to chat with my Service Advisor after dropping my car on the Sales side to have them rectify the clear bra. Anyway, he knows me and my car(s) and driving style and how I am oriented to troubleshooting and observing things and such. And when I explained the symptoms, of course he said he wants to put it on the computer and update the software, and needs it two days to do that. I knew that would be the response. He doesn't know or expect that there would be any faults logging, but he did say that he has seen cars that have had the software updated/reinstalled 3 and 4 times before and suddenly all the issues were resolved. He did offer and agree that it seems like it's a computer/software issue with regards to the computer talking to the transmission. And he also said that he hopes (as I do) that a software reinstall would actually resolve things. And he has an X3 in right now that is being reprogrammed for a loose mirror and said he'll go drive it this afternoon with my comments in mind and see if he experiences anything similar.

So the good news is that sure, it "might" be a software issue. The bad news is that of course I have to bring it in and leave it for two days, which for me is not an easy thing to do as it means a hotel stay. So I'll schedule and do it in a few weeks and we'll see what happens.
Reply With Quote