View Single Post
  #18  
Old 07-02-2012, 07:12 PM
Fast Bob's Avatar
Fast Bob Fast Bob is online now
Keeping it surreal
Location: Here, there, everywhere....
 
Join Date: Jun 2004
Posts: 34,080
Mein Auto: 2004 330Ci ZHP 3 pedals
Quote:
Originally Posted by Stork501 View Post
I would have to look at the battery and check all of that, this was suggested on fanatics:

***Rule out the simple things first. Clean your TB, DISA, ICV, and MAF. Reseal the DISA with german auto solutions seal, and TB with genuine BMW T seal. Clean ICV with brake cleaner and MAF w/ MAF cleaner (though many say they've cleaned their MAF with carb or TB cleaner and is fine) I'd just buy the right stuff. Not damaging your $200 maf is worth the chance of wasting an extra $5 on MAF cleaner vs. TB cleaner***
Being SURE you have a solid, reliable power source **IS** the first step....without that, doing all this other crap doesn`t mean a thing.

Quote:
Originally Posted by Brobby87 View Post
Not to totally steal the thread but I figured I'd post it here rather than start another thread. I have the same issue only no EML light. The other two (DSC and Brake) have came on and stayed on since they started. I've been driving like this for half a year now. Luckily the past winter here in Iowa wasn't bad.

Even though the EML light is not on could it still be one of the wheel speed sensors?

I've had no funky electrical gremlins so I'm almost certain it's not the battery
You`d better consider a closer analysis of that last sentence, Sport....
__________________
The road goes ever onward....
(R.I.P. Jever)

*Please support the Wounded Warrior Project*

When faced with choosing between two evils, always go with the one you`ve never tried before....
Reply With Quote