Thread: Last few issues
View Single Post
  #122  
Old 07-10-2012, 01:30 PM
bmw-mania bmw-mania is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Feb 2011
Posts: 1,336
Mein Auto: BMW
Quote:
Originally Posted by Dakota_leWarne View Post
THANK YOU!!

Ill try the o2 sensor first.

I just checked all my vacuum hoses again yesterday and insured that none are leaking or are pinched.

yes if i rev it past 1-1.5k it truns right off, it comes on when i stay at any rmp for 10-15 seconds but goes away if the rpms drop or rise.

No fuel leaks that i can tell and ive spent quite a bit of time under the car so i assuem i would have noticed.

Idle control valve has been cleaned and if it is unpluged the car will die.

Is your evap system for the fuel tank breathing properly?
Are all the gaskets on the intake manifold seated proper?
Not Sure? Pull/push gently on intake manifold.. look/listen for idle RPM changes..
Throttle Position Sensor?

^^ for all that stuff i have absoluty no clue
Find out.

Inspect, check, clean, the throttle position sensor on the side of the throttle body.
Inspect, check, and find out if your intake manifold is leaking.

Check engine temp sensor also.. If it works.. you'll know.

There is a tiny hose on the fuel pressure regulator that tends to crack over time.
It attaches to the under side of the intake manifold and its very possible a leak in that tube would not be detected.

Vacuum check..
-intake boot to valve cover
-intake boot to ICV
-ICV to manifold
-manifold to FPR
-manifold to brake booster
-TB to charcoal canister
__________________
Quote:
Originally Posted by cj.surr View Post
I don't have to read the username on these posts to know who wrote it.

Bmw-Mania, Ladies and Gentlemen.
Reply With Quote