View Single Post
  #1  
Old 08-25-2012, 03:59 PM
randyw419 randyw419 is offline
Registered User
Location: Ohio
 
Join Date: Aug 2012
Posts: 4
Mein Auto: 1996 BMW 740iL
Exclamation 96 740iL - Fuel Pump and Wiring Problems

To start off this is my 1rst BMW. Its a 1996 740 iL with 160k miles and needs a lot of work. I considered replacing the engine but that may not solve the problems Im having. I put a new battery in but there is acid in the tray. They previous owner put what Im assuming is a stereo system and blew the alternator. Anyways it fires up with starting fluid and dies. Ive put together the engine part by part. Anyhow I disconnect the hose at the fuel rail and dirty old pump out. I put new fuel and replaced the filter. The filter had no pressure so when I checked the pump it isnt switching on. Keyed on position 2 only 1 wire has 12v and that a constant in any position. I found 3 relays in the engine compartment, 3 above the battery in the trunck, and this is where I have a major problem. In the cabin I have no center console components such as a rdio, climate control ect. I have found 3 more relays, 1 tall black relay, there is a plug hanging down with no resistor. Its inline with 2 thin gauge wires. Whats worse I have 2 wires with eyelets that are attached to nothing. 1 is red/blue. Right now Im just trying to figure out why I the fuel pump isnt kicking on. I also heard that it might have an inertia switch. Im over my head right now, but this car just grows on me and I hate to get rid of it. Any suggestions on any of these issues?

Last edited by randyw419; 08-26-2012 at 07:18 AM. Reason: addition
Reply With Quote
Ads by Google