View Single Post
  #3  
Old 09-18-2012, 01:15 PM
fhinfo fhinfo is offline
Registered User
Location: Seattle, US
 
Join Date: Dec 2011
Posts: 26
Mein Auto: F10 535i xDrive
Quote:
Originally Posted by fhinfo View Post
Wow! I will try this later
OK! Here are the results I have tried! I was SUPER surprising after something happened!

First I have tried other languages such German. Then I went by following steps and made the German language worked!!

KOMBI -> 3008 PIA_Einheiten -> Funktionen -> Sprache -> uk / werte 01
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_MASTER -> english_uk
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_1 -> english_uk / werte 02
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_2 -> fransoesich / werte 06
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_3 -> deutsch / werte 01

Everything looked so good. So I tried to do some Asian languages, which is tough and hard to figure out.


As before, whenever we have contents with Non-English languages may show "squares" on iDrive and "?????" on cluster. For example:




Then I just follow by the instructions above and make some changes by following

KOMBI -> 3008 PIA_Einheiten -> Funktionen -> Sprache -> china_traditionell / werte 09
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_MASTER -> chinesisch_trad
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_1 -> chinesisch_trad / werte 0A
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_2 -> chinesisch_simp / werte 0B
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_3 -> english_uk / werte 02

After these steps were done, I selected the language in iDrive with the selection "blank" on the screen and this was what happened



Scary right? lol

But go back to the cluster, here was what happened.


Chinese display OK!!!!!!!!!!!!! WOW


Japanese display OK as well!!!!!!!!!!!!!!!!!


No problem with Recent contacts! No more "??????" !!!

you can see the Chinese characters on the left down side, which is "Doors Open!" It depends on the language selection in the iDrive. So if I change it to "Chinese_Simplified", "Doors Open!" sign will be changed as well. But the bigest issue is.... there is no language pack installed in the iDrive. So it would cause the iDrive screen blank at all. I can't let this stupid thing happen. So I change the value by following and everything works good!

KOMBI -> 3008 PIA_Einheiten -> Funktionen -> Sprache -> china_traditionell / werte 09
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_MASTER -> english_us
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_1 -> english_us / werte 03
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_2 -> spanisch / werte 04
HU_CIC -> 3000 HMI -> Funktionen -> LANGUAGE_3 -> franzoesisch / werte 06

Yes! Just change KOMBI -> 3008 PIA_Einheiten -> Funktionen -> Sprache.

That's it!

HU_CIC settings remain as original. In this case, you won't lose anything in your iDrive such as Navigation and so on. Also you will get Asian languages display on the cluster as well.

Last edited by fhinfo; 09-18-2012 at 07:08 PM.
Reply With Quote