View Single Post
  #3  
Old 10-15-2012, 11:09 AM
idriveE60 idriveE60 is online now
Registered User
Location: califorina
 
Join Date: Oct 2012
Posts: 13
Mein Auto: 2004 e60
increased emissoin follow up on repairs .

i replaced my disa intake valve the flap that controls the air was snapped open and had no function and caused rough idle and increased emissions fault when i pulled it out the seal around it was flat and had no contour and had an air leak around the seal ,and new hose on secondary air valve to pump ,and new pump the old was kinda filled with carbon build up
was due for replacement .while i was down in the motor i checked all connection to ensure no other issues were present ,i found the crank case vent hose split in half but you could only tell the hose was split by actually touching it that hose is far down the motor had to remove all air intake components to get to it , after replacing all necessary items i have a smooth idle she runs like she supposed to , it seems like these issues were present for a while ,because i had a slight oil leak but couldn't find the source until now wow what a mission ,no ses light on no codes

here are some pics of what was replaced




Click image for larger version

Name:	IMAG0357.jpg
Views:	83
Size:	94.5 KB
ID:	345810

Click image for larger version

Name:	IMAG0353.jpg
Views:	73
Size:	60.4 KB
ID:	345811

Click image for larger version

Name:	IMAG0362.jpg
Views:	72
Size:	103.4 KB
ID:	345812

Click image for larger version

Name:	IMAG0356.jpg
Views:	79
Size:	63.8 KB
ID:	345813

Click image for larger version

Name:	IMAG0345.jpg
Views:	66
Size:	85.1 KB
ID:	345814

Click image for larger version

Name:	IMAG0347.jpg
Views:	72
Size:	72.6 KB
ID:	345815

Click image for larger version

Name:	IMAG0348.jpg
Views:	70
Size:	91.3 KB
ID:	345816

Click image for larger version

Name:	IMAG0351.jpg
Views:	69
Size:	69.9 KB
ID:	345817
__________________
Reply With Quote