View Single Post
  #15  
Old 10-25-2012, 05:40 PM
Hemorrhage Hemorrhage is offline
Officially Welcomed to the 'Fest
Location: Pennsylvania
 
Join Date: May 2012
Posts: 277
Mein Auto: BMW 335xi
Quote:
Originally Posted by DSXMachina View Post
Hmmm. I love random misfires. They're tough but very satisfying to figure out. With your engine we have to start by agreeing that the misfire isn't the cause but the effect. Something is going bad and it results in different cylinders misfiring. Based on the symptoms I think we can assume that your compression is good, and that your mechanicals are all functioning properly.
That leaves the problem with spark or fuel. Either you are randomly not getting spark or not getting fuel. The fact that you are not always getting a CEL tells me a lot about what it isn't, not an answer, but we're making progress. If I had your car in a bay I would take a look at short term fuel trim to see if you are constantly running borderline lean, that would point to either a bad air/fuel ratio sensor (you call it an oxygen sensor), or a bad mass airflow sensor, or a bad throttle position sensor, or a bad intake air temperature sensor.
The whole key is that the engine is not immediately setting a code.
Why? Because the computer thinks the bad device is sending a good signal, in other words the signal may be bad but it's plausible! Example: You install a Super Duper oil soaked intake air filter. The oil vaporizes and condenses on the mass airflow sensor. It cokes up over time and insulates the sensor wire. At 50 mph when the sensor should report 42 grams per second of air it reports 35. The condenser then commands enough fuel for 35 grams of air which results in a very lean mix. The mix gets critical under stress conditions (like accelerating) and a cylinder -or many cylinders- run so lean they missfire. Then the A/F ratio sensor sees all those unburned hydrocarbons going down the exhaust and -guess what?- CUTS BACK on the gas because it assumes you are rich when in fact you are lean. Now your engine is shaking like the San Andreas Fault on a bad day. You let off the gas and things get a little sorted out for a while.
See? It gets complicated. I doubt we are going to be able to help you resolve this problem without good information and without a graphing scanner you can't give it to us.

Or your intake valves could look like the La Brea Tar Pit. Tip o' the hat to Orient. His record is good on this subject.
After trying everything that I did...the only thing I could think of would be a bad O2 sensor.
That, and maybe a clogged cat. Does that sound plausible?

I don't know...I'm still an apprentice technician going through school.


The car is under warranty. I WOULD just take it to BMW, but the idiots won't give me a loaner because I'm not 21. I guess people under 21 shouldn't take their car in for repairs.
Reply With Quote