View Single Post
  #4  
Old 11-06-2012, 07:07 PM
QAfred QAfred is offline
Officially Welcomed to the 'Fest
Location: Panhandle of Florida
 
Join Date: Aug 2008
Posts: 919
Mein Auto: 328i, 330ci, R1200C
Quote:
Originally Posted by Starless View Post
This was my third drain and fill. The first one was done with original ATF - Texaco ETL 8072B, second and third ones with Castrol Dex 6. I went with Dex 6 because that's what BMW now recommends for GM hydromatic transmissions.

The result is not so good. The car now is sluggish, with slow, soft, long shifts. It feels like something is holding it back, as if climbing up the hill. No slipping , but does not feel right at all. Not good.

The level is fine, I'm an expert at doing this by now having done it 3 times.

I'm planning to drain and fill again with different ATF.

Just a warning - be careful what you put in your AT.
I doubt that is your transmission causing those symtoms SL. I believe you have a MAF or Throttle body or something else going on there. Dexron six is just another hydraulic fluid that meets previous spec. Worked fine on my daughters 2004 325ci.

However, did you ever do the memory reset? I read in this forum that you can turn the key on, engine off, depress gas pedal to the floor for 30 seconds and that resets the computer. So it doesn't drive like the person who was in it previously etc. I know that was probably you but would not hurt to try it.

I tried this on my wife's 323i and it seemed to get snappier afterward...i.e. slightly different shift points? not sure.
Reply With Quote