View Single Post
  #4  
Old 11-10-2012, 03:26 PM
autoque autoque is offline
Officially Welcomed to the 'Fest
Location: Canada, etc
 
Join Date: Jul 2008
Posts: 179
Mein Auto: BMW
Quote:
Originally Posted by floydarogers View Post
What is broken?
Not quite sure, even after more than three years of trips to various dealers and master techs, no one knows what's wrong.

I've got a warm start rough idle which lasts one to two minutes after the ignition. This started right after replacing the cylinder head under warranty for a tapping noise, a well known issue in the N52 engine. They changed the spark plugs, coils, MAF and cleaned various parts, tuned up the timing of the valves, disassembled and reassembled, the symptom got a little better, but never disappeared. So my final desperate move, throw expensive parts at it, especially suspicious is the cylinder head unit, which started this long painful journey. I'm out of warranty so I'm picking up the tab, but the dealer's willing to forgo the labor cost since they know I've been having this problem early on. However the dealer doesn't know whether the replacement will lead to fixing the problem as their diagnostic device tells nothing's wrong.

The whole head costs like over $5000 so I thought replacing the valvetronic and vanos is more sensible to a rough idle problem. By the way, absolutely no fault code stored except a code was found about a month ago indicating an error with the vanos solenoid valve, so the dealer replaced it rather than cleaning it and using it again, hoping it would solve the problem. But no go.
Reply With Quote