View Single Post
  #1  
Old 11-12-2012, 06:47 AM
745iguy's Avatar
745iguy 745iguy is offline
Besessen Deutsch Autos
Location: Massachusetts
 
Join Date: Apr 2012
Posts: 1,133
Mein Auto: 2006 X5 3.0
Did some work yesterday

Changed the seals on my vacuum pump (o rings)
But before i even took out the pump i noticed my oil pressure switch was dripping oil at a fast rate so i changed that before i took the pump out Deep socket 24 and a 3" extension and i got it out without removing the vacuum pump, although i did remove it and replace the o rings anyway.

After that oily mess I had the SES come on a couple days before so i read it out with INPA and got P2187 P2189 (too lean at idle both banks) and then pending codes for both banks for the secondary air system throughput too low.

What are the chances that these 4 codes could have something to do with eachother? I read somewhere somebody changed a precat o2 sensor, and they lost one bank code of the secondary air, also read that too lean could be o2 sensors, fuel filter, vacuum leak. car now has 144K on it. Keep in mind my car is running a euro DME ZUSB and has a lot more tolerance for the secondary air system.

Any insight would be appreciated

Edit: Also I have the updated CCV's that i have put in recently (within a few months) so i dont think its the CCV's (for the lean codes)
Attached Thumbnails
Click image for larger version

Name:	IMG_0188.jpg
Views:	202
Size:	132.8 KB
ID:	349232   Click image for larger version

Name:	IMG_0192.jpg
Views:	192
Size:	156.2 KB
ID:	349233  
__________________

06 X5 3.0 Toledo Blue Metallic/Light Beige 2:
Adaptive Xenon Headlamps, Panoramic Sunroof, Rear Sunshades,
+Factory Aux Input in Ashtray, Bluetooth, Rear PDC Sensors, Rear Electronic Adjustable Seat Backs,
+White Angel Eye LEDs, +5000k LED H11 Foglights, +Blacked Out Chrome Grill Surround, +Puddle Light Logo Projector
.. more updates to come

PREVIOUS 2002 745i

Last edited by 745iguy; 11-12-2012 at 07:58 AM.
Reply With Quote
Ads by Google