View Single Post
  #1  
Old 11-12-2012, 04:44 PM
rooster1986's Avatar
rooster1986 rooster1986 is offline
Officially Welcomed to the 'Fest
Location: Columbus, Ks
 
Join Date: Dec 2009
Posts: 521
Mein Auto: 92 325i
Bucking like a bull

For the last week my 92 325i has been giving me whiplash. It idles perfectly and if you slam the gas it shoots foward but...... Say Im just cruising through town/highway the car will stall, allmost die (dash lights flash for a fraction of a second) then pick right back up like nothing happened. I took the car for a drive tonight and with the engine warmed up and goinga constent 25mph it stalled 5 times in a 4 square blocks.

It doesn't do it when coming to a stop and at full throttle it won't but if your at a constant speed or slowly excelerating it does it. I pulled the codes and only got 1216 (TPS) I put a new one on today and fixed nothing. Before the idle was crappy but now it's fine with the new TPS. I even disconected the battery and reconnected it with out any results.

One last thing, after my last run I pulled the air intake off to look at the inside of the throttle body. I opened full throttle and puffs of gasy smelling smoke came out. Don't know if thats related or not.
__________________
Primered Black 92' 325i. Ireland Engineering Header, Ireland Engineering Catback, TMS Underdrive pulleys, TMS chip, Bav auto fpr, Power Flow cai, Bav auto coil packs, Cool Carbon pads, Eiback springs, Bilstien Sport HD shocks/struts, 3.23 LSD, Understeer short shifter, 16'' Spal Fan, Goodridge Steel Brakelines, M3 Bumper, Black out grill, clear tails, M3 mirrors.
Reply With Quote
Ads by Google