Bimmerfest - BMW Forums - View Single Post - Nav screen scrambled/fuzzy?? Help??
View Single Post
  #15  
Old 11-13-2012, 05:17 AM
1bad540's Avatar
1bad540 1bad540 is offline
Officially Welcomed to the 'Fest
Location: newyork
 
Join Date: Jan 2006
Posts: 10,417
Mein Auto: E65 750i Sport,C5 z51 e46
Quote:
Originally Posted by tonywintn View Post
Just saw this post. The scrambled screen issue is due to a dirty ribbon cable connection. That is all it is. I first had the issue where I would loose the color blue. The ribbon cable from the screen to the nav unit has no connector on it, just bare conductors on the end. The ribbon cable plugs into a receiver/connector in the Nav unit that clamps down on it. I pulled this cable out and cleaned the contacts. That solved the problem for a couple of years and then one day I had a scrambled screen. I was able to just tug lightly on the cable behind the screen and fix the issue, but I need to take the unit out and clean the contacts again. Use Deoxit contact cleaner. You can buy it at Radio Shack. It is also popular amongst us audiophiles for cleaning our audio cable contacts. Very good stuff. So the problem is not your screen, just a corroded connection.
wow thanks, so i would need to take the screen out and clean the ribbon contacts??
__________________
[SIGPIC]
e39 540i sprt, acs type 2's,acs pdls,clrs(sold)
e65 745i sprt,21's aib's acspdls, rf splr(sold)
e46 328i 18" 335spt whls(sold)
c5vette 6sp,z51,2"drp,19"ccw'sshrt shft,corsa exh,dd nav(sold)
e53 X5 3.0, pna rf,nav,xnon,cldwthr,20"4.6rims.(sold)
e65 750I aw, sprt. 21's,acs pdls,acs rfsplr,mtecs,8k hid(sold)
Srt10 VIPER, 19-20" forged,tune,corsa ex,intake.
w221 S550 amg,dia white,5%3m tint.20"s63rims,lwrd
e70 3.5 aw.mtec, powdr blk whls.
e46 M3vert,6spd,19"HRE,bbk,ext,intke
Reply With Quote