View Single Post
  #1  
Old 11-13-2012, 10:47 PM
e39540iv8 e39540iv8 is offline
Officially Welcomed to the 'Fest
Location: Australia
 
Join Date: May 2012
Posts: 141
Mein Auto: 2000 BMW 540iA
E39 540i Electrical Issues

Hey guys, just need some help on the enigma aka my 540i.

I came to start the car 3 days ago and the car started weirdly and the cluster didn't work. I also heard weird noises so I turned it off. I tried starting it a few hours later and the car wouldn't turn over, only "click". Now the battery is pretty old, over 3 years but the little button thing on it doesn't show white which means replace. I know that it's not accurate but could this be a battery issue? I say this because now the interior lights, seats and general electrics work sometimes and sometimes they don't. So like I open the door, the interior lights up but I come to do it maybe an hour later it doesn't. Then after say 4-5 hours it works again and then it just doesn't.

The cluster didn't work while the car was running the last time I turned it on which led me to believe the cluster had blown but then the electrics started acting weird and now I just don't know what's going on. Car mechanics show no sympathy either, they charge so much for such little work. I've spent over $3k on this car already and it hasn't gotten better. It's not that I don't have money to spend it's that I don't wanna spend a fortune on this thing. This is by far the most unreliable car I've driven.

Anyways does anybody have any clues I'd really appreciate it.
Reply With Quote
Advertisement