View Single Post
  #14  
Old 11-15-2012, 03:41 AM
QSilver7's Avatar
QSilver7 QSilver7 is offline
Officially Welcomed to the 'Fest
Location: Northeast Indiana
 
Join Date: Aug 2008
Posts: 5,662
Mein Auto: 1997 740iL / 2006 X5 4.4
Quote:
Originally Posted by iKosova View Post
I did an oil change and put 6 to 6.5 litres of synthetic oil 5w 30

Now I have did about 8700 - 9000 KM's and the oil light came on and turned off
I have also checked the oil level and its below the low line

...
Where are you getting the info that your car requires 6 to 6.5 liters of oil? If its the owners manual...then your model year must be different than mine. My 2006 owners manual says the 3.0 X5 requires 1 to 1.5 liters more than what you put in.

If this is the case...your issue is more than likely you started out with too little oil in the crankcase. The "oil light" is designed to come on when you are approx a quart/liter low...and if you only put in 6-6.5 liters...again, you were already a liter to a liter & half low. I'm surprised that it too 8700-9000 kilometers for the oil light to illuminate.

Please refer to your owners manual just in case your model year is different than the info in my model year owners manual:


owners manual says 8 quarts or 7.5 liters of oil for the 3.0 X5

__________________
Q {BMW CCA Member #191509}
2006 E53 X5 4.4i (Sterling Gray) 12/05 mfg date <<~>> 97 740iL (Arctic Silver) 3/97 mfg date
(SOLD)
99 540iT (Orient Blue) <<~>> 95 525IT (Alpine White)
91 735iL (Schwarz Black) <<~>> 85 325e (Bronzit)

http://imageshack.com/scaled/grid240/822/e38e532ndsigpic.jpg

Last edited by QSilver7; 11-15-2012 at 03:53 AM.
Reply With Quote