View Single Post
  #7  
Old 11-17-2012, 03:50 PM
RPsX5d RPsX5d is offline
Officially Welcomed to the 'Fest
Location: Bay Area California
 
Join Date: Nov 2010
Posts: 596
Mein Auto: X5 Diesel xDrive35d
Got the CEL again after doing a long weekend trip - ~1,100 miles, which included hwy and city miles plus mountain climbs to about 8,200 feet. Same OBD2 error code (P20EE) - second time over a month period.

Here is a brief summary of the events since the original EGR recall.
  • Per the original recall EGR valve + programming was done
  • About a month back SA told me I also needed the mixer replaced - this involved mixer + programming
  • Two weeks later I got the CEL - they replaced the NOx sensor
  • A week later I got the same OBD2 error code (P20EE) . . . this time I told the SA most likely the hardware is fine, software must kicking out these error codes . . . and replacing parts most likely will not fix this issue. Tech agreed with my reasoning but said he has to follow the procedure dictated by BMW

Following is what the tech told me after completing the latest repair work.
  • They replaced the catalytic converter - see attached for work performed
  • Tech admitted on a few cars after the last re-programming they are seeing cases where catalytic converter needed to be replaced.
  • Tech said - it appears the new programming is more sensitive than the previous one - and this "might" be the issue - i.e. old programming was not this sensitive
  • The new catalytic converter has a new part number - this could be due to some design change and/or catalyst itself is different. Tech doesn't know what the changes are
  • So far cars that got the EGR and SCR Mixer replaced + the latest programming + new catalyst have not come back with CEL . . . too few cars have had all of this done, so too early to say this problem is fixed
I continue to be impressed by the customer service Kevin/BMW Concord is offering . . . no BSing, where they don't know the answer they simply admit it, honest about the limitations BMW places on them, etc etc . . . on this visit, since they had to test drive it much longer than normal, they gave me a full tank of diesel - nice touch!

I will post if CEL pops up again . . . will be driving about 1,000+ miles over the Thanksgiving weekend.

As always if others have had similar issues please do chime in . . . I am skeptical this issue is fully fixed . . .

BTW this car is a blast to drive on those deserted twisty mountain roads - I was hitting 70+ miles on those curves, worked the brakes really good . . . I could have never done any of this on my previous SUVs! With AD it would have been an even bigger blast! Oh well . . .
Attached Thumbnails
Click image for larger version

Name:	BMW X5 - Replaced Catalyst.jpg
Views:	140
Size:	229.8 KB
ID:	349870  
Reply With Quote