View Single Post
  #243  
Old 11-19-2012, 04:49 PM
FenderBender's Avatar
FenderBender FenderBender is offline
Needs Boost
Location: Hicktown, PA
 
Join Date: Apr 2008
Posts: 11,287
Mein Auto: Red Sled
Got a couple of things done today. First, started putting the interior back together, have the windows all wired up now (weren't before) and mostly everything done. I'm also trying to fix the leak around the fuel pump assembly, if I fill it up the whole way it spews out. I put a new o ring in and I'll fill it up tomorrow and see what happens.





Front of the interior is mostly done, needs a cleaning now for sure. I'd also like to redo the seats sometime, ideas? Products? Experience?

Again, low quality low light pictures.






Check out my new gas pedal yo, been driving it without one at all for the last month! lol




Injectors showed up, look very very nice. All new O rings and the like, not bad for 68 bucks shipped total.








Runs GREAT!! No miss at all, climbs all the way to redline. I figured something was up with the injectors, the rest of the fuel system is new (soft lines, filter, pump, pressure regulator) as is the spark plugs, wire, cap, and rotor. I also used up 3/4 ish of a tank and only got 94 miles. One or more of them were stuck open for sure. One other thing to note is the the injectors tested perfectly with a multimeter.


Now the only problem is idle, there is no miss anymore but it isn't quite right. Bumps up and down sometimes, and is always high (1500rpm if not more)


I cleaned the ICV but maybe I killed it in the process? Like I said I don't think there are any Vac leaks but who knows.
__________________
Turbo Build Here


Reply With Quote