Thread: iDrive
View Single Post
  #7  
Old 11-19-2012, 04:05 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,565
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by Yorgi View Post
Try popping out the NAV DVD and see if that helps. Someone mentioned once that the DVD was their source of a slow iDrive boot. If removing the disc makes a difference try a new DVD.

I think the main source of the general overall sluggishness is an underpowered CPU on the CCC versions of iDrive.
This is correct on all counts, I actually had suggested the DVD removal option. I suffer from slow boots and had the dealer upgrade and work on my system a couple of times with no change. Well, there was a slight change, before the update it took forever to get to the past the splash screen to the initial screen and was unresponsive until then. Now, it boots pretty quick to the initial screen but is unresponsive for the same amount of time. So I have stereo selection screen but cannot use it!

After testing I found that not having the NAV disc in the system booted much quicker. I still keep the disc in however since my Wife can get lost at any time, she is terrible with directions! Since it is her daily driver we just deal with the boot issue. If it was me driving the car everyday I would pull the disc in a heartbeat.

Lets face it, our version of the Idrive was archaic and pretty weak when it was new, so it is certainly weak when compared to other more modern systems. My friend who has a 2005 CL55 AMG seems to have a more robust system.

Last edited by tampamark; 11-19-2012 at 04:07 PM.
Reply With Quote