View Single Post
  #1  
Old 11-30-2012, 09:49 AM
crfloyd crfloyd is offline
Registered User
Location: FL
 
Join Date: Nov 2012
Posts: 7
Mein Auto: 2008 535i
Unhappy Not a great first experience...

I am posting this in hopes that there is someone else out there who has experienced a similar problem as mine and can offer some advice. I purchased my first BMW on October 31st. It is a 2008 535i. It was a one owner car with low miles (46k) and seemed to be problem-free.

About 9 days after I bought it, I got a "Shift Lever Malfunction" message that started coming up periodically while driving. I took it in to the BMW service center and they replaced the shift lever ($1k) and all seemed to be fine for about a week. The shift lever error came back randomly while driving one morning. I thought maybe this was a fluke because it popped up so fast. A couple days later, I was sitting in a Wendy's drive-through and the error came up and my power windows, locks, seat and mirrors all shut off and the light on my steptronic shift turned off. I could not place the car in park or anything else. After turning the car off and back on, everything seemed to be ok but the same "shift lever malfunction" light would come on and off.

I took the car in to the dealership again and they have had it over a week now. They have replaced the body control module but according to them, the error came up while they were test driving it so I guess it is back to square one. I can not believe that my first experience is like this but I hope there is someone out there who has had similar problems that can offer me some advice. Thank you in advance.
Reply With Quote
Advertisement