View Single Post
  #12  
Old 11-30-2012, 03:09 PM
SeanMH-6 SeanMH-6 is online now
Officially Welcomed to the 'Fest
Location: Clarksville TN
 
Join Date: Nov 2012
Posts: 116
Mein Auto: 2002 525i sport, premium
ok so i finally got time to get into the car, its on stands right now. i reset the codes and only two came back. those two were...
both the secondary air injection codes. p0492 and p0491.

quite frankly, i don't know what a secondary air pump is beside what you told me fudman, i don't have time too search read up on it now, just making a quick post.
THAT BEING SAID, found a disconnected line. air line. if you were looking at the engine, it would be the near left corner of the engine bay. the line was connected to what i believe is my SAP. right behind my right fog light (right as in if you were driving the car right). tried connecting it again couldn't get it to click but i didn't spend much time on it. hopefully the other codes don't come.

found the coolant leak. confirmed it is the radiator, right under the upper hose. replacing all the hoses, expansion tank, thermostat as well.

have "brake" light illuminated on dash. manual says it means bad pads on what cluster, and on a different cluster it could mean a fault in the bmw braking system. have to research that, and buy new brakes anyways, so that isn't too much of a concern to me.

valve cover is leaking bad, going to pick a new one up tomorrow from the dealer for a whopping 80 something. have to look up that as well.

ill keep everyone posted with the codes. engine and airbag code.

thanks to everyone monitoring, it definitely helps when im so time constrained to have feedback from you guys.

Last edited by SeanMH-6; 11-30-2012 at 03:11 PM. Reason: missing info
Reply With Quote