Thread: Transmission
View Single Post
  #4  
Old 12-01-2012, 09:03 AM
oltom oltom is offline
Registered User
Location: Floida
 
Join Date: Nov 2012
Posts: 18
Mein Auto: 530i
Bacpque

Not sure if this is in the transmission or something to do with the main computer itself. However if this problem is in the tranny the valve body sounds like the culprit. In the valve body two things may cause this. The solenoid controlling the shift is failing, but has not totally failed yet. The solenoid is running intermittently for one reason or another. Second possible problem a shuttle valve in the transmission valve body is sticking. Need to know is your transmission a ZF 5HP or a GM 5L40E? Sounds like a ZF. If its a ZF you'll find a colored sticker on the transmission oil pan probably located drivers side forward. What color is that sticker green, black, other. The sticker on mine was cover in road grim and could not see it, but its there. let me know. You said the transmission was rebuilt right? What type of oil was put in after rebuild? Need the name and number (exp. Esso ATF LT 71141) of the oil. BMW oil is not an answer to this question. Correct answer would be something like the following Mobil**** Esso**** Pentosin**** Royal Purple**** TS **** (total source), Dextron***, or other. Miles since rebuild? For the most part shooting from the hip the good news is that if the valve body is the problem. You probably won't need to drop the tranny unless the wrong oil was used to top off after rebuid. For now we'll forward from here.
Miles since over haul?
Type oil used after rebuild?
Was converter replaced?
Type of transmission?
Reply With Quote