View Single Post
  #1  
Old 12-26-2012, 01:17 PM
sun3301 sun3301 is offline
Officially Welcomed to the 'Fest
Location: Silicon Valley
 
Join Date: Jul 2004
Posts: 133
Mein Auto: 2001 330ci Ti Silver
Question Accidentally drove with low oil levels

Guys, I have the common yellow oil level light come on at start-up and then go out on my 2001 330ci, 5 speed. The sender unit is bad. I had the car in the dealer last year for some work and they saw the light was coming on even after they changed the oil. But didn't change the unit because they had just buttoned it up.

So the car has about 7 thousand miles on from that oil change. Because I was so busy recently, I didn't check the oil till yesterday and saw that I was below the dipstick! I added a quart and that got the oil level up to the stick, but halway, so I need another 1/2 quart of so.

I know its my fault for not checking, but I hope I didn't do any permanant damage to the engine. With the oil level sensor being questionable, hopefully it not turning red meant that oil pressure levels were still at the ragged minimum before I added the oil. The engine sure sounds better. But I didn't have any issues before I added oil, except at highway speeds I could hear some noise that I thought was tire noise. The engine has 86,000 miles on it and driven for most part very easily by this original owner. No jack rabbit starts and speeds at 65 when no traffic.

I may for the first time change the oil myself on this car and do the sending unit too. I've changed the oil regularly on my vintage Mustang myself, but not on this car. It scares me a bit!

Thanks for any insight. I hope the engine is pretty tolerable to the low oil level.
Reply With Quote
Ads by Google