View Single Post
  #1  
Old 12-27-2012, 11:39 AM
J.Laco J.Laco is offline
Registered User
Location: Amsterdam
 
Join Date: Dec 2012
Posts: 4
Mein Auto: BMW e65 750i 2007
750i NAVI03 Initialization problem

Dear BMW fellows,

Since 3 days ago my NAVI03 unit simply stopped working.

When I insert the DVD in the Navigation Unit "light illuminates in the CD" but then the system displays the navigation screen "Initializing ..." and nothing else happens until the past few minutes the screen gives a flash and restart in order to appear again "Initializing".

In the same time radio is reset as well due to the MOST connection of the components.
Everything else is working just fine: radio, CD, CD charger, iDrive, telephone, Logic 7, etc...

I noted that the BMW Assist screen also displays "Initializing" forewer.

What can be the problem ?

I consulted the secret i-drive menu and my version is NAVI03 DVD from 02 07 2007. The software version is:
Navigation:
sotware version: 09.04. hex
Date of manufacture: 2007 02 07
Part number: 6590 9 122860

Some trials to solve the problem:
- I was suspecting the DVD Rom reader and replaced is yesterday. It did not solve the problem.
- I have an original Europe High navigation DVD from my dealer. I also copied / burned another DVD in order to see if the DVD-Rom was the problem. Same "Initializing" screen forewer.
- Also serveral times I reset the MOST fiber optics (from the trunk glove compartment), but didn't help as well.

Can you pls give me any hints: can it be the GPS signal (tribmble box integrated within the Nav unit)? Nav computer? Is there any fuse or relay that can cause this problem (all seams fine).

Your help is appreciated.

John

Last edited by J.Laco; 12-27-2012 at 01:09 PM.
Reply With Quote
Advertisement