View Single Post
  #1  
Old 12-27-2012, 07:27 PM
mannynews mannynews is offline
Registered User
Location: Hoboken, NJ
 
Join Date: Dec 2012
Posts: 2
Mein Auto: 2005 BMW X3 3.0i
Mystery Electrical Issue

Over the summer, lucked up on my first car purchase and found a 2005 BMW X3 3.0i with only 3,900 miles on it. I've been enjoying it, virtually problem free, except for this recurring issue that seems to be getting worse...

At random times, maybe every other time or so as I start the vehicle...there is a noticeable flickr in the headlights, and also the interior lights. Occasionally, the car's electrical system seems to stop, and restart itself immediately (the 4X4 light, and a few other lights come on, but then go off).

I've taken this to the local Pep Boys.....had them check the electrical system and battery....they said that something electrical seems to be on, even when the system is shut off. They thought the problem could be with the aftermarket radio.

Took it to the shop that did the radio, had them completely remove the radio, then reassemble it. The problem stopped for a while....but then returned.

Left it with the BMW Dealership for a few days, the problem did not replicate itself. They also checked the battery power (its the original battery), and report all is fine...they kindly did not charge me for anything....but said to keep in touch.

Since this is my first car ownership experience....can anyone offer assistance in troubleshooting this issue? Like many of you, I love my X3, replaced the tires earlier than needed, get the oil changed on a regular basis, and keep it in great condition. This electrical issue is one I want to resolve....so I can continue to safely enjoy the vehicle..

(One side note...wondering if this could be a weather related issue? Maybe it's getting worse because it's colder?)
Reply With Quote
Ads by Google