View Single Post
  #20  
Old 01-05-2013, 12:11 AM
bluskye bluskye is offline
Officially Welcomed to the 'Fest
Location: chicago
 
Join Date: Jul 2002
Posts: 795
Mein Auto: 2006 330i / 2007 X3
Quote:
Originally Posted by uncle spike View Post
I just got a 2013 328i. After driving it for approximately 700 miles, I noticed a clicking/tapping noise after the engine is shut off. The noise goes on for about 10 minutes. It is a loud tapping noise that sounds off along with the normal ticking sound after the car is shut off.

This is quite unbelievable. I had to returned a 2012 service loaner with less than 5,000 miles that I purchased because it was giving off a grinding noise at 15 mph that the dearlership could not fix. After numereous back and forth and headache the dealer finally gave me a 2013 as a replacement. Now the 2013 car is giving me problems too. BMW's quality has definitely gone down hill. I had a 2000 323i for eleven years and never experience the problems like these. Just unbelievable.

This is a joke right? Dont most BMW turbos engage the electric waterpump after engine shut-off to cool it after? I think I heard some commotion about fuel pumps doing stuff after engine shutoff too.

Welcome to the world of turbos.

Here's another neat fact of BMW electric waterpumps, you can trigger them to bleed off the coolant system after you change the fluid. Go figure, it makes a weird sound when its pumping fluid with the engine off to bleed off the air for get this, 12mins!

Last edited by bluskye; 01-05-2013 at 12:12 AM.
Reply With Quote