View Single Post
  #7  
Old 01-10-2013, 02:34 PM
tampamark tampamark is offline
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,913
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by gregb View Post
Presumably you already tried the transmission reset to allow the transmission to "relearn" your driving behavior, and this didn't correct it? If not, turn you car on (but don't start it), and depress the gas pedal all the way down (past the kick point) and hold it down for 45-60seconds. Then start the car normally.

Also, I had some irregular shifting on my '07 auto and the dealer checked it for me this week. They found that the mechatronics sleeve was leaking and the fluid was a little low. They replaced it for me and covered in under CPO. Not sure if this is "mechanical" versus seals/gaskets, but it was covered.

Good luck.
They replaced my mechatronics under CPO also, but it is a Sealing Sleeve and a hard part (plastic?), not a rubber seal/gasket. That is all I can come up with to say why! A picture of what it looks like is in the following writeup

http://www.zftranspart.com/images/custom/mecha.pdf


The mechanical is just a general rule of thumb, there are some mechanical they do not cover, and other items that aren't purely mechanical that they do. When I was in for service one time I pointed out that the hydraulic stabilizer rack under the front of my car was leaking a bit of fluid. Not much, but when I was inspecting some other stuff I spotted it. They took a look, the SA said to me, if it is a seal/gasket that needs replacement I am out of luck, if it is the entire assembly then I am covered. Luckily they cleaned it up, tightened it, and it didn't leak anymore. So no charges came down either way.

Last edited by tampamark; 01-10-2013 at 02:39 PM.
Reply With Quote