View Single Post
  #136  
Old 01-19-2013, 08:44 PM
resistro resistro is offline
Registered User
Location: usa
 
Join Date: Oct 2008
Posts: 31
Mein Auto: 740
Got a similar problem trying to diagnose MOST bus.


http://www.bimmerfest.com/forums/sho...d.php?t=671068

Here's my problem:

"BMW" is only displayed (PIC#1)on the navigation screen (unless I break the MOST fiber loop-more info later). Wont do anything! No radio, chime, voice control, ect.

I tried that trick to bypass modules (ASK CD player, Voice Controller, CD changer, L7 Amp, Tuner) to exclude them from the MOST bus but not seem to be gaining any ground. I took that factory fiber loop from the glove box to bypass these modules.....

FYI: I did not have to purchase a spare, I just took the loop connector apart and connected the two end together (the fiber ends in the glove PIC #3)-this seemed to do the trick. It seems if ring bus is broke the red LED does flash, when connected red LED stays light. I took the actual fiber optic line out of the connector housing and used it for bypassing.

......1) when I used the 'fiber loop' to bypass any the modules in the trunk and including the ASK or CD changer in the dash (PIC #5), nothing happens. 'BMW' logo will still be displayed on the screen.
2) when i take any of the modules out of the network ring (unplugging ANY of the modules-not 'bypassing' anything) I DO GET the 'accept' prompt on the nav display (PIC#7) and can navigate through some functions but can operate only the climate functions. No Nav(PIC#8) or radio (PIC#9), chime, ect. I can only scroll through.
3) I also tried that trick to go into the MOST diagnostic screen (PIC#10), but nothing comes up under the 'MOST' menu. Again, the only way can control anything on the Nav display is when the MOST fiber ring is broke. If I try to connect the fiber ring back together at that point, it will just freeze on whatever is display I have up.
4) Nav disk DVD does seem to spin and eject fine. Although I have noticed it will still spin when the ignition is off.
5) Dash CD player seems to a spin the CD, but no sound of course.
6) CD changer tries to eject a the cartridge. But it never worked anyway.
7) All the modules seem to be transmitting light via the fiber.

Basically, the 'BMW' logo stays on when everything is connected and I cant do anything.

I got my whole car torn apart and need some advise on what to do next?
Do I need some software to reset the ghost errors after bypassing each module?
Reply With Quote