View Single Post
  #37  
Old 01-21-2013, 01:52 PM
Piers1989 Piers1989 is offline
Officially Welcomed to the 'Fest
Location: Newcastle, UK
 
Join Date: Mar 2012
Posts: 302
Mein Auto: E65 745i
I just tried this on my 745i.

Have some SERIOUS problems. I'm not new to using the BMW toolset and I'm an IT tech so I understand how stuff works generally speaking.

I tried this flash to update the gearbox in my car as I had been experiencing the hard 2-1 shift.

As it started updating I got the transmission warning on the dash (I assume is normal), and it started doing the flash. I waited as it went through, it hit 100% after about 4 mins.

It did not say succeed or completed, but popped up the same message (press ok to program 11 flashes remaining or similar - 1 less than before the start). I pressed okay on that one, the bar was still at 100% in the background but the status at the bottom of winkfp was "ready", but the program hung. I waited another 10 mins or so but nothing happened.

The car still says transmission failsafe gear cannot be displayed, and will not go into any gear.

INPA can no longer access the gearbox (saying something like it is responding but can't be recognised).

I can't flash it again with winKFP as it says the UID is incorrect (or similar).

I CAN connect to it with tool32 (have done reads only) and it is still responding, but a couple of the flash read options say the UID is incorrect.

I understand I can unbrick the ECU with tool32 but I don't know how, I've never used it before.

Can anyone help??

EDIT: FIXED IT AND SUCCESSFUL UPDATE.

Used tool32 to send a reset command after googling what the German things meant.

After this (still completely unusable) I was able to re launch winKFP and re flash the module.

took about 25 mins to do the flash this time :o (3-5 min hang, then slow flash over5 mins, then 3 min hang, then fast flash, then hang, then slow flash, then hang).

After this i had a load of errors on the DME DSC and SIM.

Cleared them all, and now its working

Will post an update if it fixed the problem tomorrow

Last edited by Piers1989; 01-21-2013 at 03:12 PM.
Reply With Quote