View Single Post
  #49  
Old 01-23-2013, 02:03 PM
stuartjohn24 stuartjohn24 is online now
Officially Welcomed to the 'Fest
Location: Chippenham, Wiltshire, UK
 
Join Date: May 2011
Posts: 664
Mein Auto: BMW E65 745i
Well... Things started looking up! But... I noticed following further testing that some of the address lines between the processor, EEPROM and RAM were held low during some power-ups on random occasions. Sometimes the address lines would work intermittently, or do nothing for several power-ups. This became more and more frequent, I tried freezer spray on areas of the board to see if that changed things.

Spraying freezer spray onto the processor instantly makes it start working, sadly this points to the processor (1 in my picture above) itself being at fault. Pretty annoying, however being determined to fix this to save myself the cost of a new AMP I tried some other things as I have nothing to lose now.

Considering the failure of the main power supply regulator circuit and the subsequent over voltage of the 5V rail I started again with the EEPROMs, they seem to be working as some code is being read so that CPU kicks the watchdog. I removed the EEPROM labelled 3 in the picture and tested again, The address lines now have clean signals on them and I have tried 30+ power-ups using the fibre port and cycling the main power supply and it works perfectly every time.

Im wondering wether the EEPROM is heavily loading the processor address or data lines causing it to hang or over current or the chip select and output enable function of the EEPROM is not working and its writing data when the processor or RAM is trying to. Hopefully the EEPROM may be readable using a bench programmer, fingers crossed and I will program a new one.

Otherwise I will be on here begging for someone to read the code for me!

Stuart
Reply With Quote