View Single Post
  #4  
Old 01-24-2013, 06:51 AM
Iceeberg Iceeberg is offline
Registered User
Location: Missouri
 
Join Date: Jan 2013
Posts: 22
Mein Auto: 2004 BMW X5
The BMW dealership did the cv boots but it seemed like the issue started after it was in the shop the last time. On inspection we found a transfer case leak so I took it to the dealership and they replaces the seal on the transfer case and a transmission gasket they found leaking also. They must have been very minor because there were only a couple spots on the garage floor. After I picked it up the "check engine" light came on as soon as I hit the highway. I took it back 2 times to check codes and they basically just deleted them, the third time I left it with them, they said one was a "mis fire" and the other an "o2 sensor" warning. They said there were 3 o2 sensors on the car and they checked 2which were fine, then they changed the spark plugs thinking that the mis fire was triggering the o2 sensor. They said the light eventually went off and they couldn't get it back on to see which "bank"? The o2 sensor was coming up. They kept it a week and drove enough that they went through a tank of gas, but they said if the light came back on they would replace the o2 sensor for free. The car doesn't drive bad other than the vibration. It feels like if something was stuck to the tires or maybe loose in the front end? But only at higher speeds. Bmw said caution on the ball joints but when I took it to a dependable local shop they said they were nice and tight. Any advice would be appreciated Kay
Reply With Quote