View Single Post
  #8  
Old 01-24-2013, 02:29 PM
Stephen Max Stephen Max is offline
Registered User
Location: Austin, TX
 
Join Date: Jul 2010
Posts: 64
Mein Auto: 1998 M3, 2004 545i
Quote:
Originally Posted by svett View Post
Hey Guys,
I too have this issue for about 2 weeks. Reset the code twice using my new Android Torgue app (Droid Razr) in conjunction w/new Bluetooth OBDII (Excel) diagnostic plug device. Code came back again...now after some research I have to dive in and do a complete systematic air flow check. These links will help: 2nd one is pg 6

http://www.bimmerfest.com/forums/sho...ary+air+system

https://www.bavauto.com/newsletter/2...newsletter.pdf

https://wiki.bentleypublishers.com/d...es+2004+-+2005

I will check back in w/ my findings!


Thanks to everyone for the posts in this forum, I have learned a lot and saved thousands!

Steve
The first two links are not applicable to your 545i. Unlike the 6 cylinder engines, the N62 SA system does not use vacuum operated check valves, and the fresh air is routed through the heads into the exhaust ports, not into the headers. The CEL is activated when the O2 sensors don't sense a lean shift due to fresh air entering the exhaust during SAP operation. This can be due to a cracked y-pipe under the intake manifold, stuck check valves, or clogged SA ports in the heads. Unfortunately, clogged ports are quite often the problem. This requires removal of the heads and drilling out the carbon. Some people over in the E65 forum have claimed success in opening up the ports using solvents and wire brushes, but I spent a week doing that with no success. So, it's head removal time for me. Fortunately, I have the means and the know-how to do the job myself.
__________________

Last edited by Stephen Max; 01-24-2013 at 06:25 PM.
Reply With Quote