View Single Post
  #48  
Old 02-05-2013, 01:34 PM
mgarciah mgarciah is offline
Registered User
Location: Costa Rica
 
Join Date: Sep 2012
Posts: 92
Mein Auto: 320i, X3 and X5
Quote:
Originally Posted by invisihitch View Post
PAX5 -- If you are inclined to code the hitch option yourself, there are other X5 owners on this forum who have done so successfully and would probably be willing to provide some guidance. It is not complicated. I believe I saw in the thread entitled "Coding" that blue dragon coded his own hitch, so you may want to PM him.

Even if your software is not up to date, applying the hitch option works most of the time. You just need to check the trailer brakes afterward to make sure an older module is not preventing the trailer brake lights from operating. If they are working, you are good to go. If not, I know of no workaround. You would have to get your software updated and then re-apply the hitch coding.
Brake light doesnt work because the AHM (trailer module) comes programmed for europe by default, so it comes ready to handle the 7 pin connector that comes with the OEM harness, in US and in Latin America the OEM harness comes with a 7 to 4 pin adapter because we use the four pins connector, but the adapter is not enough, in 4 pins connector brake lights are left turn and right turn on together, in europe (7 pins) there is a separate cable for brakes, so you need to code your AHM and change it from "ece" which means europe to "us", this will tell the AHM to turn on LT and RT on brakes.
Reply With Quote