View Single Post
  #20  
Old 02-26-2013, 06:39 PM
Dass Dass is offline
Registered User
Location: Mississauga
 
Join Date: Sep 2012
Posts: 11
Mein Auto: 2005 BMW 645ci
Thank you!!!!!!!

I have had this engine light/"increased emission" for the last 7 months. The shop I work with has changed valves, seals and valve covers all over the friggin place totalling about 6g's. Because I have an after market warranty I didn't pay too much attention.

But then the car started stalling and shaking. This time they told me it was the vaccum lines. I let them go at it and again...stalling and emission light.

Then I decided enough was enough.... After reading through this forum I came to understand there was a diagnostic wire specifically targeted or geared towards BMW vehicles. I purchased the Bavarian Technic diagnostics wire and downloaded the software. I found the error messages as listed above which lead me to this thread. I have purchased the ccv pressure valve kit x2 I figure I'll do both sides while I'm at it. There was a slice or hole in the diaphragm. Let's hope this is it, but I'm confident this is or was the issue. Thanks again.

Symptoms again:
Shake at stop.
Stall after warmed up and idling or reverse (low rpms)
Increased emissions light
Engine light
Large cloud of blue smoke on long idle 3-5 min
Spontaneous bouncing rpms at low idle

If at any time I reset/clear the fault all problems were resolved for about 100km

Cheers.

Last edited by Dass; 02-26-2013 at 06:41 PM.
Reply With Quote