View Single Post
  #29  
Old 05-01-2013, 11:37 AM
scottjays scottjays is offline
Officially Welcomed to the 'Fest
Location: SoFla
 
Join Date: Feb 2010
Posts: 108
Mein Auto: 2014 BMW X3 35i M Sport
agree with Jimsan 100% total BS

Drew:
was very excited to try this. it did connect and show "update successful"
but still google maps are not sending to car
same error:
Sorry, we were unable to send this message at this time. Please visit the help page.

Quote:
Originally Posted by Jimsan View Post
BMW Assist is a joke as far as I am concerned. I picked up my X3 on April 10th and still my "data has not been loaded." Seriously who is responsible for this fiasco? I think they must subcontract this out to some company? I have called them at least 4-5 times. Why aren't they loading the information for cars delivered earlier?

I assume if I really had a problem I could call them and get the service I need.
Quote:
Originally Posted by Drewsky View Post
For everyone having trouble with your BMW Assist on your '14 and/or missing services: go into your connected drive menu, toward the bottom is a "services" item, then in there is a "update" selection. Do that and the vehicle will talk to BMW. After I did that, 100% of all of my services work, including my web browser! Neato! I dont know if it will correct everyone's troubles, but it cant hurt!
__________________
2014 BMW X3 35i M Sport Carbon Black, Nevada Chestnut, Wave Wood. Driver Assistance, Premium, Technology, M Sport, Dynamic Handling, Premium Sound and Heated Front Seats.
Reply With Quote