Thread: Burning oil?
View Single Post
  #16  
Old 05-07-2013, 02:46 PM
edgt edgt is offline
Registered User
Location: Long Island , NY.
 
Join Date: May 2013
Posts: 6
Mein Auto: 545i
2004 545i issues oil, tranny slip, electrical? Anyone??

Quote:
Originally Posted by bimmerfan52 View Post
Hi Brian,

Congrats on your purchase of an awesome machine. The 8 cylinder models are beasts!

When you post, please try to give as much information as you can about your vehicle and situation so some of the more experienced readers can give you an opinion.

For example:
1. How many miles total do you have on the car?
2. How many miles have you driven since July? Have you changed the oil since you purchased it?
3. Do you know anything about the previous service done to the car? Specifically how often the oil was changed.
4. Have you noticed any leaks or had the front belly pan off to look underneath the engine and in the belly pan for stains?
5. You ask about adding a quart every couple of months but don't tell us how many miles you have driven or approximate hours the engine has been operated.

Hi All,
I purchased my 2004 545 i as a certified preowned vehicle in 2006 with 18k miles on it. I love the car but it is supper expensive to maintain. I have recently run into a few other issues that are making me rethink its value. I now have 91k on the odo and car is immaculate looking.
Issue 1... Tranny slips or seems to be searching for 5 or 6th gear while cruising at 35 to 40 mph.

Issue 2... While driving with heads up display on and radio, it appears that they both cut out for a split second. the display flashes on and off sporatically about 1 per minute.
I have recently had the battery changed and this seems to have appeared afterwards.

and finally,,,,

Issue 3... Oil leaks and burning. I know what the issue is here seals and valve issue.. Been in contact with bmwoem1 on this.

Any suggestions would be helpful.
Thanks
Ed
Reply With Quote