Thread: Burning oil?
View Single Post
  #17  
Old 05-07-2013, 04:08 PM
jim165 jim165 is offline
Officially Welcomed to the 'Fest
Location: Texas
 
Join Date: Oct 2006
Posts: 548
Mein Auto: 2008 BMW 550i Sport
Quote:
Originally Posted by edgt View Post
Hi All,
I purchased my 2004 545 i as a certified preowned vehicle in 2006 with 18k miles on it. I love the car but it is supper expensive to maintain. I have recently run into a few other issues that are making me rethink its value. I now have 91k on the odo and car is immaculate looking.
Issue 1... Tranny slips or seems to be searching for 5 or 6th gear while cruising at 35 to 40 mph.

Issue 2... While driving with heads up display on and radio, it appears that they both cut out for a split second. the display flashes on and off sporatically about 1 per minute.
I have recently had the battery changed and this seems to have appeared afterwards.

and finally,,,,

Issue 3... Oil leaks and burning. I know what the issue is here seals and valve issue.. Been in contact with bmwoem1 on this.

Any suggestions would be helpful.
Thanks
Ed
#1 Have the tranny fluid level checked...could be low? Ever had it serviced (fluid change)?
#2 Was the battery registered when it was changed? I'd get one of those little battery/voltage monitors from Autozone that plugs into the lighter socket to monitor what kind of voltage you're getting...could be an alternator issue:



#3.XXXXXX
__________________
2008 550i Sport-a.k.a. Hot Kraut Garbage

Others:
2006 Corvette Conv, Z51,6sp (wife)
2007 Honda CBR1000RR Sold
2005 Triumph Daytona 650 (wife) Sold

Reply With Quote