View Single Post
  #1  
Old 06-23-2013, 11:31 AM
alex md alex md is online now
Officially Welcomed to the 'Fest
Location: NORTH NJ
 
Join Date: Nov 2005
Posts: 774
Mein Auto: 2014 X5 50 M sport
Poorly functioning AC in 2013 X3

Hey Everyone-

Just looking for advice although I am pretty annoyed with this issue in my 2013 X3 3.5 MSport.

I have been a BMW customer for 15+ years and had multiple cars (as witnesses by my signature). I never had this issue in any car. The AC is not functioning properly. I have been to the dealership twice. The first time they kept the car for a day and concluded that everything is OK. The second time they kept it for two days and acknowledged a lower level of coolant than usual. According to SA, they refilled coolant level. The last couple days, I have been driving my car in 85 degree weather and keeping the AC at 68 and high fan and still not comfortable in the car. Obviously, I did all crude and minor adjustments with red, blue as well as recirculating and it has gone nowhere. On Monday, I am planning to go back to the dealership and discuss this issue with Service Department Manager as well as BMW NA. This car barely has 3,000 miles and we didnt know about this issue until the real heat wave began.

Thanks for any advice/guidance to be provided.

Alex

P.S. No evidence of coolant leakage because as per SA, they put dye in the coolant.
__________________
2014 X5 50 Msport
2013 X3 3.5 ZMP,ZCW,ZPP,Carbon black/black/wife/ 2011-2014 550xi M sport/ED/
2007-2011 X5.4.8/E70/
2010-2012 GLK 350/wife/
2008-2011-328XI
2004-2007-CLK55
2007-2010-X3 3.0
2001-2004-A8 4.2
2004-2007 X5 3.0/E53/
1999-2001-SL500
1996-1999-ML320 4MATIC
1992-1995-VOLVO 850 TURBO
1990-1992-525I
1987-1990-OLDSMOBILE CS
1981-1987-LADA/VAZ 2103

Last edited by alex md; 06-23-2013 at 11:34 AM. Reason: Forgot to add a note
Reply With Quote
Ads by Google