View Single Post
  #1  
Old 10-04-2013, 08:41 AM
iamkevski iamkevski is offline
Registered User
Location: NJ
 
Join Date: Apr 2013
Posts: 11
Mein Auto: 2014 X3 28i
Angry Rear Liftgate Motor Broke - 7+ weeks waiting for part from Germany

I just went to the dealer today to check on the status of my service, since it's been 4 weeks with no update...

I dropped my x3 2.8i at the dealer on 9/4 to get the rear power liftgate serviced, because the motor was only lifting it about 1/2 way up or down, and then stopping.

The dealer confirmed that it was a defective motor, and said they'd have the part shipped from Germany shortly, since they didn't have it.

Apparently, there is a production problem on this stupid part, and BMW can't get it out the door for some reason. After 4 weeks with a loaner, I called, and they said it's still on order. I went down to get my car, because the loaner x1 was not very fun... When I got to the dealer, they told me that they've been having problems sourcing parts from Germany for a few weeks now, especially with these liftgate motors.

Anyway, thought I'd share my story. I'm definitely turned off on the whole BMW experience based on this, and now the recall. It seems like quality went way down over the past couple years. Hopefully it's just my experience, but I can't believe that I'll have a broken liftgate for over 7 weeks, minimum, with no part to replace it. As soon as that gets fixed, it looks like i'll have to bring it back for the engine recall...

Very bummed out.
Reply With Quote
Ads by Google