View Single Post
  #39  
Old 11-15-2013, 11:22 PM
bluebee's Avatar
bluebee bluebee is offline
Seek to understand,^Value
Location: San Jose, California
 
Join Date: Mar 2008
Posts: 22,028
Mein Auto: 02 BMW 525i M54 auto 130K
Here's a potentially blown engine posted today:
Quote:
Originally Posted by mpx View Post
After many other hours spent reading this forum, I found the numerous posts about engine diagnosis. I want to thank you for the patience you had to answer my questions, even when similar threads were already available.

I purchased a new battery and checked that I have spark. I have fuel, I can hear the fuel pump running when I short the pins on the relay ( and the relay is good) and I always have gas squirting whenever I release the Schrader valve on the fuel rail after I crank the engine. But the engine wouldn't start even with starting fluid.

I only have compression in cylinder 6. I measured: 1(30),2(20),3&4 almost zero,5(30) and 6(120)psi. I figured the cylinders must have been flooded on several occasions while cranked so I added some transmission oil in each cylinder. That increased compression by at least 20 psi in all except for the middle ones. #6 increased to 200psi.

Given that the engine most likely overheated when the serpentine belt broke, should I start shopping around for a new engine after what I found out? But I should still take the heads off and see what I find, right? The engine should have the iron block, what is the best scenario I can hope for and what special tools would I need?
__________________
Please read the suggested threads, where the best always add value to those threads, either by pictures or by descriptions, so the next person with the same problem stands on your shoulders.
See also: E39 Bestlinks & How to easily find what you need
Reply With Quote