View Single Post
  #13  
Old 10-28-2004, 09:35 PM
Iniquity Iniquity is offline
Officially Welcomed to the 'Fest
Location: Phoenix/Tucson/San Diego
 
Join Date: Sep 2003
Posts: 175
Mein Auto: 2003 330i ZHP
oh no.. that sucks.. i thought they didn't even replace the vanos unit? i thought they changed the valve control unit next to the intake manifold on your car? i'm getting my car back tomorrow.. we'll see what they say.. i'm a little worried they didn't do anything.. because id didn't get a callback.. and my car was finished in 2 days (that i know of).. last time it took 1 week because they had to order the part..

i expect tomorrow when i call and ask what was done.. they'll tell me the oil service was done, no such thing as SW39.2 (or 39.1) and never heard of 4k powerloss or rough idle/stall that it's supposed to fix, tell person how to close gas tank properly, and also couldn't duplicate vanos rattle... aftermarket exhaust may be causing all problems.. void warranty and charge for oil service.. i swear, if they tell me i'm not closing the gas cap tightly i'm gonna krav maga someone's butt... i seriously hate this dealership.. but they're the only one within 120 miles or so.. although it's free .. can't wait till my warranty expires so i can take it to an indep. bmw or euro shop where they only hire master techs..

i'll let you know..

Something is definitely wierd though.. that only 2003 ZHP's are coming up with the problem.. i still think it's an oil pressure problem of some sort
__________________
If you don't like my driving, get off the sidewalk.