Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)

E28 (1982 - 1988)

Reply
 
Thread Tools Display Modes
  #1  
Old 03-07-2008, 04:47 PM
Rono190 Rono190 is offline
Registered User
Location: Adelaide, Australia
 
Join Date: Jan 2008
Posts: 1
Mein Auto: 1982 BMW 520i (E28)
1982 BMW 520i instument cluster

hi all

i have just bought a 1982 BMW 520i which has been sitting at a mates house for 5+ years and i have a few small problems with the car

problem 1 - the temperature gauge and the fuel gauge
the temp gauge slowly moves up and reads in the red. all cooling is good
the fuel gauge shoots up to max fuel even though the fuel tank is not full
we suspect it may be an earthing problem are we on the right track?
i have just read about a similar post about problems with the earthing cable under the steering column!!
we have also changed the batteries on the cluster

problem number 2 - the engine does not idle correctly it peaks and troughs constantly

if anyone has any ideas on solving any of the problems?

thanks in advance for any help with this problem

Ron

Last edited by Rono190; 03-07-2008 at 04:58 PM. Reason: noticed information in another thread
Reply With Quote
Ads by Google
  #2  
Old 03-08-2008, 08:16 AM
jimoreno jimoreno is offline
Officially Welcomed to the 'Fest
Location: Parsippany, NJ
 
Join Date: Jul 2006
Posts: 487
Mein Auto: 2006 X3
If the batteries had leaked acid the board is probably corroded. Look at the ground under the steering column (you'll need to remove the under dash cover). As for the erratic idle is most probably due to the Idle Control Valve (ICV). Remove it and clean it with carburator cleaner as it gets full of gunk. If that doesn't help it might be defective and needs to be replaced. Your car might also have the Idle COntrol Module (ICM) which sends the signal to the ICV and they work together.

Good Luck!
__________________
Jimmy Moreno
1995 530i
1986 535i
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E28 (1982 - 1988)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 03:05 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms