Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 09-20-2009, 02:42 PM
nickmetha nickmetha is offline
Registered User
Location: Houston, tx
 
Join Date: Oct 2008
Posts: 40
Mein Auto: BMW X5 Diesel
Help-----2004 X3 2.5L jerking issues-----

I was driving today and the check transmission light came on.....and after that the service engine light came on.

Car drives weird.....I have AT and when it switches down from 3-2-1 it hesitates badly.

Anyone had similar issues? Please help!!!!!

Thanks for your help.

Last edited by nickmetha; 09-20-2009 at 03:04 PM.
Reply With Quote
Ads by Google
  #2  
Old 09-20-2009, 03:27 PM
Supercourse Supercourse is offline
Officially Welcomed to the 'Fest
Location: British Columbia, Canada
 
Join Date: Feb 2008
Posts: 3,091
Mein Auto: 2004 X3 2.5i
Haven't had exactly that,
but once had the AT light come on simulataneously with the 4x4 light and one of the brake warning lights (ABS I think).

That happened on startup and appeared to be just an electronic malfunction, as it went away after shutdown, and left no readable codes.

It did put the AT into limp mode however, the same as yours.
According to the Owner's Handbook, that protects the transmission by limiting you to "only a limited number of forward gears".
It sure does feel odd as you mention.

Maybe your SES light came on subsequently because the emissions were out of whack with the transmission in that mode.
So the SES code may not help you identify the original problem with the AT.

I suppose warning lights that come on while you are in motion are much less likely to be just a transient electronic glitch.

Getting the ATF level and color checked might be worthwhile before having a dealer charge the diagnostic fee for hooking up their computer.

Hope it turns out O.K.
Reply With Quote
  #3  
Old 09-20-2009, 04:32 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 13,981
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
Like the post above, try to find the error codes that were stored within the DME at a local shop. I don't believe there is a way to check the ATF level. Your vehicle is in limp mode, hence the limited gears and rough shifting.

How many miles are on your vehicle.
Reply With Quote
  #4  
Old 09-20-2009, 08:49 PM
nickmetha nickmetha is offline
Registered User
Location: Houston, tx
 
Join Date: Oct 2008
Posts: 40
Mein Auto: BMW X5 Diesel
Funny thing happened....the Check transmission light went out.....Service engine stayed on. And the Check engine went out also...now no light.....is the car still in limp mode....it has 47K miles.

Went to the mechanic today......registered a code of mass air flow sensor.....probably loose connections.

Last edited by nickmetha; 09-21-2009 at 09:23 AM.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms