Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)

X3 E83 (2004 - 2010)
Talk about the E83 BMW X3 in this forum!

Reply
 
Thread Tools Display Modes
  #1  
Old 10-11-2009, 02:01 AM
LNLYCRPR LNLYCRPR is offline
Registered User
Location: Stuttgart
 
Join Date: Mar 2009
Posts: 32
Mein Auto: Liberty, X3 in July
TPMS Activation/Setup?

sooo, i decided to just bite the bullet and I purchased a set of aftermarket rims and some performance snow tires. i didn't want to waste my time looking for used X3 rims with all weather tires. at least these are brand new and are rated for the autobahn when it's nice out.

my question is about the TPMS. i had the TPMS sensors installed by tire rack, but is there an activation process or is there anything i have to do/setup for the BMW system to recognize whatever system was installed by tirerack? is this like a bluetooth function or will the BMW system just recongnize the new/different sensors?

i did a search and there were some topics on TPMS, but nothing really answered the question i have.

thanks
Reply With Quote
Advertisement
  #2  
Old 10-11-2009, 02:23 AM
LNLYCRPR LNLYCRPR is offline
Registered User
Location: Stuttgart
 
Join Date: Mar 2009
Posts: 32
Mein Auto: Liberty, X3 in July
BTW, just in case anyone is curious, this is the package I ended up going with. MB Rennen 18X8.5 and Falken Eurowinters HS439

Reply With Quote
  #3  
Old 10-12-2009, 12:38 PM
LvdB's Avatar
LvdB LvdB is offline
Officially Welcomed to the 'Fest
Location: South Africa
 
Join Date: Jan 2009
Posts: 469
Mein Auto: F30 328i Modern Line
Quote:
Originally Posted by LNLYCRPR View Post
BTW, just in case anyone is curious, this is the package I ended up going with...
Post a pic of your X3 with the new set fitted...
__________________

F30 328i Modern Line
E83 X3 2.0d

Retired: '07 X3 3.0d M-Sport - '04 X3 2.5i Sportpack - '99 328i E46 - '93 325i E36
Reply With Quote
  #4  
Old 10-11-2009, 03:25 PM
LNLYCRPR LNLYCRPR is offline
Registered User
Location: Stuttgart
 
Join Date: Mar 2009
Posts: 32
Mein Auto: Liberty, X3 in July
no one?

not trying to be a dick, but does anyone know or am I just askinga an insane question that no one has specifically answered on the X forum? anyone have an idea?
Reply With Quote
  #5  
Old 10-11-2009, 05:19 PM
ducx3 ducx3 is offline
sapper
Location: AK49
 
Join Date: Mar 2009
Posts: 360
Mein Auto: 02 WRX, 06 X3
The answer should be in your manual. On my 06, you press and hold the tire pressure button for 3 seconds I think and then drive off.
__________________
Reply With Quote
  #6  
Old 10-11-2009, 07:12 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 13,988
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
Simply reinitialise the system.

With the vehicle started and at a standstill, push and hold the (!) button next to DSC and HDC in front of the shifter. The yellow (!) symbol illuminates on the dash. At this point, simply drive off normally. The system will figure out the rest.
Reply With Quote
  #7  
Old 10-12-2009, 04:07 AM
LNLYCRPR LNLYCRPR is offline
Registered User
Location: Stuttgart
 
Join Date: Mar 2009
Posts: 32
Mein Auto: Liberty, X3 in July
thank you
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X3 E83 (2004 - 2010)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms