Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series

6 Series
The BMW 6 Series builds on BMW's sporty heritage with aggressive lines and an incredible motor to back the design up. Available in coupe and convertible trims with a standard 4.8 liter engine producing 360 horsepower and 360 lb-ft of torque, the 6-series is a popular choice that exceeds expectations.

Reply
 
Thread Tools Display Modes
  #1  
Old 02-07-2010, 08:04 AM
gillms1 gillms1 is offline
Sunny
Location: Reading, Berkshire (UK)
 
Join Date: Feb 2010
Posts: 22
Mein Auto: 2004 BMW E64 645Ci
E64 645ci 2004 Logic7 Amp replacement

Hi,

I've been having problems with my Logic7 sound system (scratching/distorted sound coming from left & centre speakers) - this happened at the same time I needed one of my Xenon lights replacing (ouch!) and BMW diagnosed it and said I need the amp and centre dash speaker replacing.

They want 1400 odd pounds to replace and fit and have offered 50% goodwill, which whilst appreciated I can't really afford after just having to pay a similar amount to replace the light.

Having read up on this, there seems to be a lot of people who have experienced similar problems and have saved alot of money by replacing the amp themselves (in some cases the amps have managed to be repaired).

So I was wondering:

1) Has anyone experienced anything similar?

2) Looking on RealOEM.com there appears to alot of iterations of the Logic7 (http://www.realoem.com/bmw/showparts...85&hg=65&fg=25) - I've come across a 65129150899 (which ended 09/2007) for 250...would this be fine to fit?

3) Anyone have any decent guides to replacing the amp? Is it just a case of hot-swapping them? I'm due to get a dension 500 installed and the audio shop I'm going to use have said if that's the case then they'll do it for me. But it would be useful to have a guide in case I have to do it myself.

4) I read a post on this forum where someone did the procedure on a 7series - the amp is located in the trunk towards the left arch of the wheel - is this the same for the 6 series?

Sorry for the long post, any info would be greatly appreciated!

Cheers,

Sunny

Last edited by gillms1; 02-07-2010 at 09:44 AM.
Reply With Quote
Ads by Google
  #2  
Old 02-07-2010, 09:20 AM
docpaulo docpaulo is offline
Officially Welcomed to the 'Fest
Location: Seattle, WA
 
Join Date: Nov 2009
Posts: 788
Mein Auto: 07 650i Convertible
http://www.bavariansoundwerks.com/ca...Speaker-Pairs/

they only have the center speakers available...

dunno about the amp... somebody else will chime in..
__________________
07 650i Cabrio CPO, Titanium Silver
Black Matte Grill
Dark Birch Wood Interior and Shifter
HUD, Cold Weather and Sports Package
Logic 7 Sound
Aluminum Racing Pedals
K&N Air Filters
Rays Master Piece REM 20" Forged wheels w/ Conti Extreme DWS
Reply With Quote
  #3  
Old 02-07-2010, 09:44 AM
gillms1 gillms1 is offline
Sunny
Location: Reading, Berkshire (UK)
 
Join Date: Feb 2010
Posts: 22
Mein Auto: 2004 BMW E64 645Ci
Thanks for the link. Anyone had any experience of this speaker?

I'm thinking of sorting out the amp first and then seeing if the speaker needs replacing or it was just BMW trying to squeeze more 's out of me.
Reply With Quote
  #4  
Old 02-07-2010, 02:22 PM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,751
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by gillms1 View Post
Thanks for the link. Anyone had any experience of this speaker?

I'm thinking of sorting out the amp first and then seeing if the speaker needs replacing or it was just BMW trying to squeeze more 's out of me.
PM me your email address, I can send you instructions in PDF format. The service manual does say that replacement involves programing/coding but doesn't go into any details, you would need to talk with a service adviser about that. I just cannot give you a definitive answer based on the info I have.

Also, I replaced my center speaker with a better speaker. So I have an OEM center speaker that I can send to you for cheap.

Either way, send me your email and I will help. If you want the speaker we can work that out privately.

The center speaker is very easy to change, the grill just pops straight up, I used a thin spatula as a puller tool, just wedged it under and slowly worked ti up around the edges. Once you have it up there are 3 torx screws. it is best to use a torx bit in a rachet since you cannot fit a screwdriver in that space. I can't remember which size torx driver to use, you will need to get a bit set and figure that one out. A set is really cheap.

Last edited by tampamark; 02-07-2010 at 02:27 PM.
Reply With Quote
  #5  
Old 02-08-2010, 06:18 PM
V8HAHA V8HAHA is offline
Registered User
Location: Atlanta
 
Join Date: Apr 2008
Posts: 39
Mein Auto: M3, 645
Would you mind sending me the pdf also? my email is samtae@gmail.com.

Thanks in advance!

Quote:
Originally Posted by tampamark View Post
PM me your email address, I can send you instructions in PDF format. The service manual does say that replacement involves programing/coding but doesn't go into any details, you would need to talk with a service adviser about that. I just cannot give you a definitive answer based on the info I have.

Also, I replaced my center speaker with a better speaker. So I have an OEM center speaker that I can send to you for cheap.

Either way, send me your email and I will help. If you want the speaker we can work that out privately.

The center speaker is very easy to change, the grill just pops straight up, I used a thin spatula as a puller tool, just wedged it under and slowly worked ti up around the edges. Once you have it up there are 3 torx screws. it is best to use a torx bit in a rachet since you cannot fit a screwdriver in that space. I can't remember which size torx driver to use, you will need to get a bit set and figure that one out. A set is really cheap.
Reply With Quote
  #6  
Old 02-09-2010, 08:26 AM
tampamark tampamark is online now
Officially Welcomed to the 'Fest
Location: tampa fl
 
Join Date: Jan 2009
Posts: 2,751
Mein Auto: 2006 650 convertible!!!
Quote:
Originally Posted by V8HAHA View Post
Would you mind sending me the pdf also? my email is samtae@gmail.com.

Thanks in advance!
I will send it a bit later today...
Reply With Quote
  #7  
Old 02-08-2010, 10:45 PM
kontir's Avatar
kontir kontir is offline
Tirona
Location: NYC
 
Join Date: May 2009
Posts: 604
Mein Auto: 750Li
If yr amp is gonne it looks like the speakers dont work either. All you need to do is replace the amp. No need to program anything. I had the same exact problem. I bought an used amp, replaced it n everything works fine! Try it. Dont buy a new amp. U can buy the same used amp 4 cheap. It does the same function. The dealer always try to get you. It doesnt require any programming. I even changed the ask unit n was told by the dealer that it needed programming. It was a biggg lie. It just needs replacement.
__________________
http://www.bimmerfest.com/forums/picture.php?albumid=2137&pictureid=8922
Reply With Quote
  #8  
Old 03-30-2011, 07:43 AM
aziz745i aziz745i is offline
Registered User
Location: edmonton, canada
 
Join Date: Mar 2011
Posts: 3
Mein Auto: 2003, 745i
Quote:
Originally Posted by kontir View Post
If yr amp is gonne it looks like the speakers dont work either. All you need to do is replace the amp. No need to program anything. I had the same exact problem. I bought an used amp, replaced it n everything works fine! Try it. Dont buy a new amp. U can buy the same used amp 4 cheap. It does the same function. The dealer always try to get you. It doesnt require any programming. I even changed the ask unit n was told by the dealer that it needed programming. It was a biggg lie. It just needs replacement.
so i was wondering When replacing the logic 7 amp does it have to be the same part number as the original amp or can It be replaced with any Logic 7 amp from any E65/E66?
Reply With Quote
  #9  
Old 04-01-2011, 01:52 PM
Icyhateinyoeyez Icyhateinyoeyez is offline
Registered User
Location: Boston Ma
 
Join Date: Nov 2010
Posts: 28
Send a message via AIM to Icyhateinyoeyez
Mein Auto: 05 Bmw 645ci convertible
Any 04 to 08 5 series or 6 series logic 7 works!!! i got one from an 08 545 and it worked awesome! took me literallly 20 mins to replace it.
__________________
Reply With Quote
  #10  
Old 09-20-2010, 01:55 PM
roughx021 roughx021 is offline
Registered User
Location: NY
 
Join Date: Sep 2010
Posts: 7
Mein Auto: 04 BMW 645Ci
My car just had the same problems as gillms1 on my 04 645Ci. My passenger side xenon went out and there is no sound coming from any of the speakers. Of course this happens when I'm out of warranty. I was able to fix the Xenon, the ballast stopped working (but now I see there is a malfunction with the adaptive lighting).

Can anyone help me with the amp issue though? Where is the Logic 7 amp located? Is there more than 1 amp? Can anyone send me a copy of the PDF tampamark has? My email is roughx021@hotmail.com. I thank you in advance
Reply With Quote
  #11  
Old 09-22-2010, 05:43 AM
30yrVeteran 30yrVeteran is offline
Officially Welcomed to the 'Fest
Location: Tucson
 
Join Date: May 2010
Posts: 145
Mein Auto: 2006 650i
Quote:
Originally Posted by roughx021 View Post
My car just had the same problems as gillms1 on my 04 645Ci. My passenger side xenon went out and there is no sound coming from any of the speakers. Of course this happens when I'm out of warranty. I was able to fix the Xenon, the ballast stopped working (but now I see there is a malfunction with the adaptive lighting).

I had the adaptive headlight fault after messing with my lighting mods. Disconnect the battery for a min or two and reconnect. That made mine go away.
__________________

06' 650i/8K lighting/custom angel eye fogs/3M clear bra/ACS pedals/JL 8W7 and Earthquake SWS-8Xs/black wrapped roof/custom lighted door sills
Reply With Quote
  #12  
Old 09-22-2010, 05:50 AM
roughx021 roughx021 is offline
Registered User
Location: NY
 
Join Date: Sep 2010
Posts: 7
Mein Auto: 04 BMW 645Ci
Thanx, will try. After I installed the ballast, the battery did drain and I had to jump the car. But I will try the disconnection method. By the way, love your lighting mods.

Quote:
Originally Posted by 30yrVeteran View Post
I had the adaptive headlight fault after messing with my lighting mods. Disconnect the battery for a min or two and reconnect. That made mine go away.
Reply With Quote
  #13  
Old 12-15-2010, 08:09 PM
Icyhateinyoeyez Icyhateinyoeyez is offline
Registered User
Location: Boston Ma
 
Join Date: Nov 2010
Posts: 28
Send a message via AIM to Icyhateinyoeyez
Mein Auto: 05 Bmw 645ci convertible
Im having the same problem on my 05 645. The left rear sub makes a pop noise when i turn the car on then when i turn the volume up it makes a crackling noise as if it was blown, So i went and bought 2 07 m6 subs from a junk yard and hooked it up and still the same. So i took the left rear liner off inside my trunk (couple of torx screws and clips)removed the amp and it looks like it was replaced already cause there was paint on it saying it was 04 645. It also had dried condensation marks, im gona try replacing it too because i heard this amps go alot on these cars because of the condensation from the amp being so close to the drains, hopefully it'll take care of my problem...:/
__________________
Reply With Quote
  #14  
Old 01-25-2011, 01:29 PM
Icyhateinyoeyez Icyhateinyoeyez is offline
Registered User
Location: Boston Ma
 
Join Date: Nov 2010
Posts: 28
Send a message via AIM to Icyhateinyoeyez
Mein Auto: 05 Bmw 645ci convertible
Talking

Replaced it with a 06 5 series logic 7 amp and everything works great now!!!!
just letting you know.
__________________
Reply With Quote
  #15  
Old 01-26-2011, 08:35 AM
gillms1 gillms1 is offline
Sunny
Location: Reading, Berkshire (UK)
 
Join Date: Feb 2010
Posts: 22
Mein Auto: 2004 BMW E64 645Ci
Hello!

What colour is your 6er? I noticed a silver 650i driving through town today!

I got my work done from one of those on Basingstoke Road - John Kleis. To be fair they do seem quite pricey, but they offered me the best deal I could find on fitting the Dension 500 system. If you want to know any more details feel free to ask away!

Just as an update to the thread as a whole - I'm now starting to experience the same crackling (at certain frequencies) and popping (when changing gears, which is very random!). Although the popping seems to have stopped a bit since my 6er was back at the stealers for the brake recall (coincidence??).

My uncle took a look at my original logic 7 amp and said there was some water damage and he cleaned it all up so I'm going to have a go at swapping them back over and seeing if that makes any difference (stealers took a look for me and said I don't have any drainage/hose problems).

Also I'm going to purchase a set of FOCAL 100CA speakers and replace my centre channel speaker (which I suspect is blown) - so if there's anyone interested I can offer the spare speaker at cost price (30 GBP).
Reply With Quote
  #16  
Old 01-26-2011, 08:46 AM
5678 5678 is offline
Registered User
Location: Berkshire, UK
 
Join Date: Jan 2011
Posts: 18
Mein Auto: 650i Sport Coupe
Mine is Monaco blue with cream. It's also filthy dirty at the moment! It's got a V8 *** plate on so stands out a bit. What about yours?

I went for an OEM iPod connection in mine and had it fitted by Coopers, IIRC it was 300? Kleis are the best option really. Definitely expensive, but they've been in Reading for as long as I can remember so must be doing something right!

Fingers crossed my L7 amp is ok so far. I've had one of the subs relaced under warranty though.
__________________
'06 E63 650i Sport
'88 E30 325i Touring
Reply With Quote
  #17  
Old 02-02-2011, 08:09 AM
coug60's Avatar
coug60 coug60 is offline
06 BMW 650i Sprt/Prem Pkg
Location: Nothern California - Bay Area
 
Join Date: Jun 2009
Posts: 944
Mein Auto: 2006 BMW 650i e64
I'm the guy who had speaker problems with his 7... To make a story short everyone said one or more bad speakers and further trouble shooting....
Researched it and purchased a used Logic7 from http://www.bmrparts.com/index.htm Bavarian Auto Recycling, one of the largest, most experienced, and most organized BMW recycling facilities in the world -- (over 10,000 BMW's dismantled) Quote from there website... After that everything worked fine.
Replacing it took me about a half hour, It took longer to get everything out of my trunk. Hot swap. no programing and you'll be good to go...
__________________

2006 BMW 650i Sport/Premium Package
+ Various Mods & Upgrades

Last edited by coug60; 02-19-2011 at 04:01 PM.
Reply With Quote
  #18  
Old 02-19-2011, 11:50 AM
wesman76 wesman76 is offline
Registered User
Location: Delray Beach, FL
 
Join Date: Dec 2010
Posts: 21
Mein Auto: 2004 645CI
Can I get that PDF on replacing the amp please? Thanks for the help.

wesman76@gmail.com
Reply With Quote
  #19  
Old 02-19-2011, 04:11 PM
coug60's Avatar
coug60 coug60 is offline
06 BMW 650i Sprt/Prem Pkg
Location: Nothern California - Bay Area
 
Join Date: Jun 2009
Posts: 944
Mein Auto: 2006 BMW 650i e64
Its not that complicated. I have only replaced one on my 7 series and I'm pretty sure its the same on the 6 series.. The amp was located in the trunk, left side, behind the cardboard fabric stuff (whatever you call it). Its approximately 12 inches long by 4.5 inches wide and deep. It was really easy. There are two connectors on the unit, one electrical and one FOC (fiber optic connector). The unit is held in place by 3 pullouts. The only tools you will need is to take the trunk cover off to get at the unit. It took me about 30 minutes and that's only because I had never done it before. Bet you I could do it in 15 or less now....
__________________

2006 BMW 650i Sport/Premium Package
+ Various Mods & Upgrades
Reply With Quote
  #20  
Old 02-21-2011, 10:57 PM
MDELO79 MDELO79 is offline
Officially Welcomed to the 'Fest
Location: Las Vegas, Nv.
 
Join Date: Dec 2010
Posts: 118
Mein Auto: X6///M & 06 ///M6
i recently have been experiencing problems with my passenger side front speaker. seems that only when i accelerate past 4300 rpm's it will distort. no matter how loud or low the volume is. i took it to the dealership and they said it was the amp. so after replacing it and paying $250 for a detuctible i took the car home and guess what????? it is still doing it. i called them IMMEDIATELY and i told them that i wanted my old amp back and a refund. they said they already threw it away and will try to fix the problem. and didnt want to refund me.... fugging BS!!! so now the car is still at the STEALERSHIP and they cant figure it out.....

any one know what it can be????????
__________________
06 ///M6 blk/blk
upgrades:
22" Forgiattos
H&R lowering springs
BMC air filter
resonator & secondary cat delete
CF front lip
CF mirror inserts
CF steering wheel cover


04 645ci convertible blk/blk MT- SOLD
Reply With Quote
  #21  
Old 03-23-2011, 03:51 PM
sms sms is offline
Registered User
Location: Scottsdale
 
Join Date: Mar 2011
Posts: 6
Mein Auto: 2007 e64
Hi All:

I've really found this thread (and others on the site) helpful and figured I'd share a bit of what I learned abotu all of this.

I've got the great pleasure of spending $1500 to replace this amp due to the drainage issue as well. Turns out plant debris plugged the drain in the convertible top and afer a car wash last Friday it went out (fortunately, due to the dryness in AZ it dried out and returned to working order). Then Monday we got rain and it went down for the count.

Had I known about the issue (and the resolution) I could have cleaned the drains at the first sign of trouble and, well, my wallet would be $1500 heavier. Better yet, I'd just keep the damrned things clean.

So, folks, I guess there's something we put on the annual check list - clean the convertible top drains. I'll be whining at BMWNA as given the problems with the drains these should have been checked as part of the service procedures.... but I expect little...

Enjoy spring!
Reply With Quote
  #22  
Old 05-25-2011, 11:21 PM
moe007 moe007 is offline
Registered User
Location: toronto
 
Join Date: May 2011
Posts: 1
Mein Auto: 645ci
amp problem

Hello All,


I just experinced the exact same problem. It was raining a lot today and all of sudden my left driver speaker started to make loud noises, and then the noise went on to right pessenger speaker and then middle speaker started to make a little noise as well.

I went in the trunk and opened up everything where the amp was located and all I saw was WATER around the amp.

I have few questions.

1) currently none of my speakers are ****ing other then all my subs are working perfectly fine, any idea wat exact problem is it?

2) im guessing the amp is gone because of the drain problem, once i replace my logic7 amp, would I still have to replace the speakers, or sometimes after replacing the amp the speakers dont need to be replaced ?

3) if these cars were on recall for drain issue, shouldnt bmw replace the amp as well because it happend due to their mistake?


anyone knows any places to repair or get used logic7 amps in toronto area

i hope after replacing an expeinsve logic 7 amp, we dont have to replace the speakers?

someone please help me out.


Thanks in advance !

Last edited by moe007; 05-25-2011 at 11:35 PM.
Reply With Quote
  #23  
Old 05-25-2011, 11:52 PM
Yorgi's Avatar
Yorgi Yorgi is online now
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2005
Posts: 3,452
Mein Auto: '04 M3 / '06 650i Cab
1. - it's your amp
2. - the speakers should be fine, no need to replace them
3. - people have tried that and BMW will refuse to cover the amp. Would not hurt to try.

Read this amp thread to find some specialists that repair the logic 7 amp.

If you read some other amp threads, you may find a few more repair companies. I don't think there are any local shops in the GTA that will have experience with BMW amps. If you want to try a local electronics repair shop do a search on the canuckaudiomart forums for recommended shops. Any competent audio repair technician will be able to fix this amp. It might take him longer due to unfamiliarity (ie it will probably cost more) but you won't have to ship the unit. Amps are not that complicated.
__________________
Straight lines are for fast cars...turns are for fast drivers
'04 M3 - track
'06 650i Cab - daily driver
'02 Highlander - kid hauler
'01 330Ci - winter beater


Last edited by Yorgi; 05-26-2011 at 12:02 AM.
Reply With Quote
  #24  
Old 05-26-2011, 08:54 PM
gsxr906 gsxr906 is offline
Registered User
Location: Canada
 
Join Date: May 2011
Posts: 16
Mein Auto: 645ci e64
Quote:
Originally Posted by moe007 View Post
Hello All,


I just experinced the exact same problem. It was raining a lot today and all of sudden my left driver speaker started to make loud noises, and then the noise went on to right pessenger speaker and then middle speaker started to make a little noise as well.

I went in the trunk and opened up everything where the amp was located and all I saw was WATER around the amp.

I have few questions.

1) currently none of my speakers are ****ing other then all my subs are working perfectly fine, any idea wat exact problem is it?

2) im guessing the amp is gone because of the drain problem, once i replace my logic7 amp, would I still have to replace the speakers, or sometimes after replacing the amp the speakers dont need to be replaced ?

3) if these cars were on recall for drain issue, shouldnt bmw replace the amp as well because it happend due to their mistake?


anyone knows any places to repair or get used logic7 amps in toronto area

i hope after replacing an expeinsve logic 7 amp, we dont have to replace the speakers?

someone please help me out.


Thanks in advance !
I had the same problem with my car, I took out the amp, took it apart and cleaned off all the oxidation on the board. its in good working condition. But u will need to reset the system. there is a tread on this forum that tells u steps on the repair. took me 30mins for the R&R
Reply With Quote
  #25  
Old 11-19-2011, 04:34 PM
N60B44 N60B44 is offline
Account Under Review
Location: Emeryville, CA
 
Join Date: Aug 2010
Posts: 85
Mein Auto: 745i 2003
If anyone interested I can fix logic 7 amps for e60, e65, e54 etc
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 6 Series
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 11:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms