Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)

7 Series - E38 (1995 - 2001)

Reply
 
Thread Tools Display Modes
  #1  
Old 10-01-2010, 07:20 AM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
Oil light flickering - Urgent help needed

1997 740i 117k miles

The car's oil light started flickering today after an engine wash yesterday. I am assuming that it is due to water in the sensor but I am a little worried. No symptoms showing of low oil pressure, or level. The oil light just dimmly comes on and flickers off never really appears to be all the way on like when you put the key in before starting.

Can someone show me a diagram of where to find the sensor that activates that light so that I can unplug it and dry it out to make sure that is the problem? I am heading on an 800mile trip tomorrow and need to make alternate plans if this is the begining of a larger problem.

Thank you all.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
Advertisement
  #2  
Old 10-01-2010, 11:26 AM
CodyItaliano's Avatar
CodyItaliano CodyItaliano is offline
Officially Welcomed to the 'Fest
Location: Corpus Christi, TX
 
Join Date: Feb 2009
Posts: 628
Mein Auto: 2001 740i
Find the oil pressure sending unit. Unplug the connector, spray electronic contact cleaner in the plug and sender. Blow dry with compressed air. That's what I'd do.

Oh yeah, at the moment I have no clue where it's located. I may be poking around wiring diagrams today anyway so if you don't find it I'll let you know if I found it's location.
__________________

*Der E38*
manufactured: 7/01
color: anthrecite metallic
wheels: style 89 E66, 19X9F 19X10R
ext. lighting: 8000k D2S & LED plate light
*want to get sport rear diff*
Reply With Quote
  #3  
Old 10-01-2010, 12:03 PM
balance balance is offline
Officially Welcomed to the 'Fest
Location: NC
 
Join Date: Feb 2009
Posts: 766
Mein Auto: 97 740iL
I would turn on the motor and either run the heck out of it for a while, or if it looks like it is going to cut off, just let it idle in the driveway for a while and let the water evaporate on its own, or you could try spraying WD-40 on all of the connections that may have gotten wet.

I would not recommend washing these motors, but if you are going to wash the motor anyway, let it run for a while until it gets hot and then start spraying degreaser or low pressure water on it, such as a garden hose, and don't get any water on any of the electronics. If you use a pressure washer on these motors, forget it, you could spend a couple grand trying to fix it.
Reply With Quote
  #4  
Old 10-01-2010, 12:36 PM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
Thanks for the advice fellas. I started it up a few minutes ago and couldnt get the light to come back on.. I am about to go hit the plugs with some electronic lube/cleaner and pray.. I ordered a new sensor just in case..


Although the light only came on after 30 miles of driving this morning.. overall I am hoping it was the water factor.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #5  
Old 10-01-2010, 06:17 PM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
So far so good.. I picked up the sensor and will put it in if the light comes back on..
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
  #6  
Old 10-04-2010, 01:32 PM
rrtec's Avatar
rrtec rrtec is offline
Bored Worker
Location: TN 37174
 
Join Date: Sep 2008
Posts: 819
Mein Auto: 540i/6 4/99
800 mile trip successful with no recurrence of the flicker.. Had to have been my overzelus washing techniques.
__________________
2001 740il Sport- Needs maintenance.. Parts ordered..
2006 Volvo XC90- Kid Hauler
FC3S LS1/6Speed
1992 BMW K75s Cafe build
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E38 (1995 - 2001)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Forum Jump


All times are GMT -7. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms