Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)

X5 E70 (2007 - 2013)
E70 BMW X5 produced between 2007 and 2013. Discuss the E70 X5 with other BMW owners here.

Reply
 
Thread Tools Display Modes
  #1  
Old 12-11-2011, 09:12 AM
admiralg admiralg is offline
Registered User
Location: UK
 
Join Date: Dec 2011
Posts: 2
Mein Auto: E70 3.0d SE
Lightbulb e70 rear light cluster question

Hello forum,
I've just purchased a November 2007 built E70 X5 SE 3.0d Auto (Uk RHD) . Happy with the car in general but have a niggle about the rear light tailgate 'section' of the rear light cluster. I can see and operate the rear fog in the lower section of the tailgate part of the cluster but the upper section doesn't light up at all unlike other e70's of the same age I've seen? Are there 'two' types of rear light cluster for the e70? I've got the LED and light pipes on the body section of the rear lights but the tailgate section doesn't light up at all?

Is this correct, can it be corrected / upgraded ? If so how?

Look forward to some comments as I'm currently having a back and forth with the supplying BMW dealer who told me there is only one rear light cluster LED fit...so why aren't mine working??

Cheers
Dave
Reply With Quote
Ads by Google
  #2  
Old 12-11-2011, 12:12 PM
AzNMpower32's Avatar
AzNMpower32 AzNMpower32 is offline
Tar Heel Faithful
Location: WNC
 
Join Date: Oct 2005
Posts: 13,976
Send a message via AIM to AzNMpower32
Mein Auto: 2014 Mazda3 GT
The LED lines directly above the rear foglight should light up as the DRL and the taillights, "continuing" from the outer portion of the taillights. If not, the LEDs are broken and unfortunately you'll have to buy a new inner-segment of the taillight.
Reply With Quote
  #3  
Old 09-18-2012, 04:16 AM
The_Bruce The_Bruce is offline
Registered User
Location: Aberdeen
 
Join Date: Sep 2012
Posts: 3
Mein Auto: X5
My rear LED light has stopped working on the passenger side. Looks like the same fault as you had Dave. How did you get on and were you able to change it out without going near a garage?
Reply With Quote
  #4  
Old 09-22-2012, 09:36 PM
alphaod alphaod is offline
Mmmmmm…
Location: NYC/Pittsburgh
 
Join Date: Sep 2010
Posts: 350
Mein Auto: '13 Range Rover S/C
If your tailgate section doesn't light up the LED is broken and you need an new assembly. Mine shorted out and replacing it was a 5-10 minute job. I did it in the parking lot of the dealership. There is only one screw and I used a leatherman tool to do it.
__________________
2013 Range Rover S/C
2009 X5 48i - Sold
Reply With Quote
  #5  
Old 09-24-2012, 01:33 PM
The_Bruce The_Bruce is offline
Registered User
Location: Aberdeen
 
Join Date: Sep 2012
Posts: 3
Mein Auto: X5
Thanks for info alphaod, much appreciated
Reply With Quote
  #6  
Old 10-07-2012, 07:16 AM
1HOT BMR's Avatar
1HOT BMR 1HOT BMR is offline
Officially Welcomed to the 'Fest
Location: California
 
Join Date: Aug 2010
Posts: 711
Mein Auto: 2011 550i 6 sp Manual+35d
Quote:
Originally Posted by The_Bruce View Post
Thanks for info alphaod, much appreciated
Did you replace the LED strip? Mine is flickering and I'd like to try fixing myself if it's easy and inexpensive. How much was the LED strip? Where is the one screw you removed?
Reply With Quote
  #7  
Old 10-17-2012, 05:50 PM
alphaod alphaod is offline
Mmmmmm…
Location: NYC/Pittsburgh
 
Join Date: Sep 2010
Posts: 350
Mein Auto: '13 Range Rover S/C
Quote:
Originally Posted by 1HOT BMR View Post
Did you replace the LED strip? Mine is flickering and I'd like to try fixing myself if it's easy and inexpensive. How much was the LED strip? Where is the one screw you removed?
The whole assembly is one piece. Also LED strip doesn't light have any LEDs in it per se, the LEDs are mounted on the circuit board that hold the brake force bulb.

As for removal, you would pop open the cover that holds the trunk illumination light and you'll see a hex bolt; unscrew that and it will let you pull off the tailight assembly. Be warned though, mine was glued on, so I have to pull with a lot of force. The replace assembly had a non-glued on a rubber/foam gasket.

And for price, the part was $150 from the dealership. You may be able to get it cheaper elsewhere.
__________________
2013 Range Rover S/C
2009 X5 48i - Sold
Reply With Quote
  #8  
Old 07-21-2013, 06:11 PM
ag1979 ag1979 is offline
Registered User
Location: Norway
 
Join Date: Jul 2013
Posts: 3
Mein Auto: X5 E70 3.5 M-sport
My 2009 E70 (pre LCI) got the same issue.
The LED-strip of the right rear cluster is flickering.. well actually it stays on a bit..
then off... on again ..off... no pattern, just random.. but not direct flickering.

Except for when unlocking the car, and the welcom lights come on, it seems to stay on.
However, when engine is running, its randomly on and off.
I am planning on upgrading to the LCI-clusters, but in fear of spening my allowance on that, and end up with the same on/off problem. Could it be the wire harness ?
Any toughts ? Safe to hope for the cluster is fried and just buy new ones, or take it to the stealership for new wiring
Reply With Quote
  #9  
Old 10-16-2012, 11:38 AM
The_Bruce The_Bruce is offline
Registered User
Location: Aberdeen
 
Join Date: Sep 2012
Posts: 3
Mein Auto: X5
I ended up replacing the whole rear light unit. Unless you have a loose connection at the plug then you will have to replace the unit as they are not user friendly.
Reply With Quote
  #10  
Old 07-22-2013, 12:01 PM
ag1979 ag1979 is offline
Registered User
Location: Norway
 
Join Date: Jul 2013
Posts: 3
Mein Auto: X5 E70 3.5 M-sport
Anyone ?
Reply With Quote
  #11  
Old 07-22-2013, 12:18 PM
blue dragon blue dragon is offline
Officially Welcomed to the 'Fest
Location: Pickering/Toronto
 
Join Date: Aug 2011
Posts: 702
Mein Auto: X5 35D
replace with LCI tail lights, problem solved. It will look nicer too
__________________


| ZCW | ZPP | ZPS | ZRC | ZSP | ZTP | 322 | 2VA | 456 | 4AD | 4UB | 610 | 655 | 6FF | 6FL | Combox + CIC + LCI Headlight/Tailight retro |
Reply With Quote
  #12  
Old 07-22-2013, 03:38 PM
ag1979 ag1979 is offline
Registered User
Location: Norway
 
Join Date: Jul 2013
Posts: 3
Mein Auto: X5 E70 3.5 M-sport
Blue dragon.
Tnx.
As long as it is the tail lights, and not the wiring harness that is faulty, I will gladly replace the old clusters with the LCI ones
Reply With Quote
Reply

Bookmarks

Tags
led lights, rear light, tailgate cluster


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > X Series > X5 E70 (2007 - 2013)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 06:37 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms