Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 06-05-2012, 12:13 AM
ImSW1 ImSW1 is offline
Officially Welcomed to the 'Fest
Location: Sacramento, CA
 
Join Date: May 2012
Posts: 165
Mein Auto: F10
TPMS PSI/Temp Data - Working or Not

I've added a spreadsheet to this post with all the data to date. Just remove the .pdf extension and you'll be able to open in Excel. So far I can't pinpoint any specific pattern.


All right folks. Attempting to track down why TPMS reads PSI and temp for some vehicles and not for others. HU_CIC, 3001 Ex Box, "rdc_safety" set to aktiv. If you set HU_CIC, 3001 Ex Box, "rdc" to nicht_aktiv it will remove the TPMS menu from the iDrive but you will still see green tires on the screen. Last note: Before the software update (Global) I couldn't get the PSI or temp labels to show. After the update I now get the labels but no readings.

Continuing from original coding thread:

Here's the data we've been collecting. Just reply to this post with the following details:

Model:
Build Date:
Delivery Date:
Status: Working/Not Working
Did you ever change the wheels and/or tires:
TPMS Type:
Tires:
Air/Nitrogen/Other: Regular plain ole air

I'm posting the answers I can find from the original thread.

Username: Ausfahrt:
Model: 2011 550i
Build Date: July 2011
Delivery Date 29 Sept 2011
Status: Working
Did you ever change the tires: YES
TPMS:BMW5 R12 KIT BMW TPMS Sensor Kit 5 Series 2011 from BavarianX
Tires: TOYO PROXES T1R
Air: Regular plain ole air

Username: shawnsheridan
Model: 2011 535i M-Sport
Build Date: 10/2010
Status: WORKING
Did you ever change the tires: Yes
Tires changed by Ind Shop/Dealer: Dealer
Tires: Michelin Pilot Super Sport (same size as OEM non RFT)
Air: Normal Air

Username: alex_c
No, I have not changed my tires at all!
I have the OEM tires with the original metal stem valves.
Model: 2012 535
Built: 8/25/2011
Status: Not working
Tires: Original RFT
gas: Nitrogen

Username: Stealth.Pilot
Model: 2012 550i
Build Date: Sep 30, 2011
Delivery Date: Oct 17th
Status: NOT WORKING
Did you ever change the tires: Yes
Tires changed by Ind Shop/Dealer: Ind Shop
Tires: Michelin Pilot Super Sport (same size as OEM non RFT)
Air: Normal Air

Username: Jeg23
Model: 2011 550I
Build Date:Jun 29th 2011
Delivery Date July 27th
Status: TPMS Working
DID you ever change the tires: Yes or NO
Tires: RFT (OEM) or Regular Tires?
Air: Nitrogen or regular or Dont know

Username: ImSW1
Model: 2011 528i
Build Date: Jul 10
Delivery Date Aug 10
Status: Not Working
DID you ever change the tires: Yes
Tires: RFT (OEM) or Regular Tires? Regular Tires
TPMS: Replaced Beru RDE 0008
Air/Nitrogen/Other: Air

I'd like to really like to hear from pre 09/10 owners with the earlier TPMS units. I know we have a few post 09/10 owners that the readings aren't registering, so I want to know if it's working in any pre 09/10 builds.

Sean
Attached Files
File Type: pdf TPMS Data.xlsx.pdf (11.3 KB, 349 views)

Last edited by ImSW1; 06-08-2012 at 10:33 AM. Reason: Added more information
Reply With Quote
Ads by Google
  #2  
Old 06-05-2012, 12:19 AM
wdimagineer's Avatar
wdimagineer wdimagineer is offline
Officially Welcomed to the 'Fest
Location: San Francisco, CA
 
Join Date: Dec 2011
Posts: 665
Mein Auto: 2013 M5
I'll add myself here... works with both sets of wheels.

Model: 550xi
Build Date: 1/2012
Delivery Date: 3/2012
Status: Working
Did you ever change the wheels and/or tires: Yes, works on both
TPMS Type: OEM, metal valve stem
Tires: Goodyear LS2 / Michelin Pilot Super Sport
Air/Nitrogen/Other: Air
__________________
Current: 2014 X5 xDrive50i ZMM - Alpine White/Mocha (Mods In Progress!)
Past: 2014 Jeep SRT - 2013 Tesla Model S P85+ - Bimmerpost Featured 2013 F10 M5 - 2012 550 xDrive - 2011 M3 ZCP
Reply With Quote
  #3  
Old 06-05-2012, 06:31 AM
alextremo alextremo is offline
Officially Welcomed to the 'Fest
Location: Boston
 
Join Date: Feb 2008
Posts: 253
Mein Auto: F10 550i
Model: 550i
Build Date: 12/2010
Delivery Date: 2/2011
Status: Working
Did you ever change the wheels and/or tires: Yes, but OEM wheels/TPMS are on the car now (haven't tested with the aftermarket winter wheels/TPMS yet)
TPMS Type: OEM
Tires: Michelin
Air/Nitrogen/Other: air
Reply With Quote
  #4  
Old 06-05-2012, 07:58 AM
Chuck W.'s Avatar
Chuck W. Chuck W. is offline
Officially Welcomed to the 'Fest
Location: Agoura Hills (LA) CA
 
Join Date: Apr 2007
Posts: 947
Mein Auto: 12 BMW 535I MS Alpine Wht
I have it and it works. What I noticed is that at times when you first start out cold in the morning it takes a minute or two for the info to come up. If the car has been driven it comes up immediately.

Model: 2012 535I MS
Build Date: 11/2011
Delivery Date: 12/3/2011
Status: Working
Did you ever change the tires: Yes
Tires: Michelin Non-RFT
Air: Plain Air
__________________
2012 BMW 535I 24,000 Miles
ED Pick Up on 12/03/2011; US Pick Up on 01/27/1012
Alpine White, M Sport, Blk Nappa, Cold Weather, Luxury Seating, Premium, Premium Sound, Tech, Sports Trans, Active Cruise, Heads-Up

Mods - Quad Exhaust Tips, HID Fog Lights, Clear Front Reflectors, M5 Spoiler, Calipers Painted Black, 12.5 mm Rear Wheel Spacers, Tint - 5% Rear, 35% Front & 50% Windshield - BlackVue DR500GW Dash Cam, Blendmount for Valentine One

Coding by tuesday (aka; itschase) (Chase)
Reply With Quote
  #5  
Old 06-05-2012, 08:50 AM
nicewonky nicewonky is offline
Registered User
Location: NYC
 
Join Date: Nov 2011
Posts: 89
Mein Auto: 2012 535i xDrive
Similar to above, no reading on start but it populates pretty quickly (within a few minutes)

Model: 2012 535xi (non-sport so 18")
Build Date: 11/2011
Delivery Date: 12/4/2011
Status: Working
Did you ever change the tires: No
Tires: Goodyear RFT 18"
Air: Plain Air
Reply With Quote
  #6  
Old 06-05-2012, 01:10 PM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 233
Mein Auto: 535i GT
Shawn coded mine last Sunday in Houston. I see the indicators on the display but don't get data (just an underline). I can also see the units in settings and make changes to them. That is, I can change from psi to bar and is shows up on the display, but still no data.

Model: F07 (535i GT)
Build Date: 12/11 (MY 2012)
Delivery Date: 4/21/12
Status: Working/Not Working: Not Working
Did you ever change the wheels and/or tires: Nope
TPMS Type: OEM metal valve stem
Tires: Dunlop DSST
Air/Nitrogen/Other: N2 (according to the valve stems that came with the car...)

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.
Reply With Quote
  #7  
Old 06-05-2012, 02:19 PM
clutchlee's Avatar
clutchlee clutchlee is offline
Officially Welcomed to the 'Fest
Location: New York
 
Join Date: Mar 2011
Posts: 237
Mein Auto: BMW 2011 535xi
Works for me fine.

Model: 2011 535i xDrive (Sport Package)
Build Date: 03/2011
Delivery Date: 5/31/11
Status: Working
Did you ever change the tires: Yes, only front (GY Run-flats to Continental)
Tires: Continental (front); GY RFT(Rear)
Air: Plain Air
__________________
_____________2011 BMW 535i xDrive_____________
Reply With Quote
  #8  
Old 06-07-2012, 09:14 AM
Griffin 27 Griffin 27 is offline
Verified Trusted User
Location: San Diego
 
Join Date: Apr 2012
Posts: 119
Mein Auto: 2012 535i, Space Grey
Model: 2012 535
Build Date: 03/2012
Delivery Date: 5/11/2012
Status: Not Working
Did you ever change the tires: YES
Tires: OEM 19" M Sport, OEM Dunlop tires
Air: Plain Air
__________________
2012 535i, April build, Space Grey, Oyster Interior, 19" M sport rims/tires, premium pkg, premium sound, side/top cameras, heated seats, comfort access, ceramic controls, OEM spoiler, painted front reflectors, 35% tint, rear Fog lights, coded to my liking.

Reply With Quote
  #9  
Old 06-07-2012, 09:33 AM
DreamCar's Avatar
DreamCar DreamCar is offline
Moderator
Location: Planet Earth
 
Join Date: Sep 2010
Posts: 2,445
Mein Auto: F10 M5
Model: 2012 535 IX m sport , 2012 535 I , 2012 535 I m sport

Status. : working

Never changed the tires.

Last edited by DreamCar; 06-07-2012 at 09:36 AM.
Reply With Quote
  #10  
Old 06-07-2012, 11:01 AM
RO-CK RO-CK is offline
Registered User
Location: GUA
 
Join Date: May 2012
Posts: 69
Mein Auto: 2012 X3 F25 20dX WY31
Maybe this is a dumb theory, but would it be possible that this particular feature working and the Sports Display (HP/Torque meter) in some cases and others not, may have some kind of relation with the fact that they don't have the CIC/Navigation Professional and only have the BMW Business system installed?

By the way, thanks @Dreamcar, Sean, Shawn and all that contributed for all this.. My E-net cable arrives Saturday!! Finally

Last edited by RO-CK; 06-07-2012 at 11:09 AM.
Reply With Quote
  #11  
Old 06-07-2012, 11:40 AM
grilodan grilodan is offline
Officially Welcomed to the 'Fest
Location: Chicago, IL
 
Join Date: Nov 2010
Posts: 242
Mein Auto: E70 X5 35i Sport Activity
Username: grilodan
Model: 2011 535i
Build Date: 08/2010
Status: NOT WORKING
Did you ever change the tires: No
Tires changed by Ind Shop/Dealer: N/A
Tires: Goodyear OEM
Air: Normal Air
__________________


- 2013 X5 35i Sport Activity (Born 08/12) - Titanium Silver /Oyster Nevada /Dark Bamboo - ZCV /ZCW /ZPS /Sport Package /Adaptive Drive /Soft-Close Doors/Running Boards /HUD /Shift Paddles /Comfort Seats /6NR /6NF
- 2011 535i (Born 08/10) - Titanium Silver /Black Dakota /Anthracite - ZCV /ZCW /ZPP /ZP2 /6FL /6NF (Sold 08/12)
- 2010 335i (Born 02/10) - Titanium Silver /Black Dakota - ZCW /ZPP /6FL (Sold 09/10)
- 2007 328i (Born 07/07) - Jet Black /Black Dakota - ZSP /ZPP /6FL (Sold 04/10)
Reply With Quote
  #12  
Old 06-07-2012, 06:53 PM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 233
Mein Auto: 535i GT
Has anyone looked for or found the code to turn the rotational monitoring code off? I wonder if that (RPS??? I think) might be on and interfearing.

I'll try to poke around tomorrow if I get some time in my car to look at the code.

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.
Reply With Quote
  #13  
Old 06-07-2012, 06:57 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,710
Mein Auto: 2011 535i M-Sport
@dmunz:
FYI. TPMS is Reifen Druck Control, aka RDC, and FTMS is Reifen Pannen Anzeige, aka RPA.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #14  
Old 06-08-2012, 06:01 AM
ImSW1 ImSW1 is offline
Officially Welcomed to the 'Fest
Location: Sacramento, CA
 
Join Date: May 2012
Posts: 165
Mein Auto: F10
No great breakthroughs so far.

Last night I activated FTMS. The RPA choice is just above the RDC FDL line (not RDC_SAFETY). It was set to nicht_aktiv, I changed it to aktiv. I now have an RPA ecu choice on my CAFD which has so many settings it's ridiculous. I was going through it, but just didn't have the time to delve deep into the tree.

I also adjusted two FDLs sitting in KOMBI that related to RDC, but my suspicion is that they are the FDLs that allow TPMS error codes to display on the guage cluster. Aktiv to Nicht_Aktiv.

This morning I started the car and reset the TPMS then drove away. Previously my TPMS display showed the pressure and temp icons (and green tires) but didn't give me anything else. I didn't get the dashes like many of you get. So after driving for about 200 ft I got the same display but with dashes now.

I'm going to change the RPA/KOMBI settings back to their original values one-by-one this afternoon to see what happens. Then I report back my findings.

Sean

Last edited by ImSW1; 06-08-2012 at 06:03 AM.
Reply With Quote
  #15  
Old 06-08-2012, 06:21 AM
DreamCar's Avatar
DreamCar DreamCar is offline
Moderator
Location: Planet Earth
 
Join Date: Sep 2010
Posts: 2,445
Mein Auto: F10 M5
I am happy to see you back on coding!
Reply With Quote
  #16  
Old 06-08-2012, 08:22 AM
Stealth.Pilot's Avatar
Stealth.Pilot Stealth.Pilot is offline
The Driver
Location: Florida
 
Join Date: Jul 2009
Posts: 4,561
Mein Auto: 2014 M5
Thanks for pushing on this Sean. I hope we can crack it.

Update on my situation is I had the dealer check the TPMS and valve stems in case the tire shop messed with them. They said I have the original OEM TPMS and metal valve stems.
__________________

2014 ///M5 Individual
Frozen Grey, Silverstone Full Merino, Piano Black, Exec Pkg, Drivers assistance pkg, LED Package, Bang and Olufsen, 20" Forged wheels
Reply With Quote
  #17  
Old 06-08-2012, 01:22 PM
miotoo miotoo is offline
Officially Welcomed to the 'Fest
Location: Zürich, Switzerland
 
Join Date: May 2012
Posts: 306
Mein Auto: F10 520d
Did everybody check this value in ICM ? 2VB is the SA code for Tire Pressure Monitor.
Attached Thumbnails
Click image for larger version

Name:	2VB.PNG
Views:	222
Size:	22.5 KB
ID:	328421  
Reply With Quote
  #18  
Old 06-14-2012, 06:44 AM
JEG23 JEG23 is offline
Officially Welcomed to the 'Fest
Location: USA
 
Join Date: Jun 2011
Posts: 316
Mein Auto: 550i
Quote:
Originally Posted by miotoo View Post
Did everybody check this value in ICM ? 2VB is the SA code for Tire Pressure Monitor.

@shawnsheridan,

Did you check this value quoted earlier by Miotoo ? In my car it is set to verbaut.

JEG23
__________________
2011 550i
Space Gray /Black Nappa, Dark Wood
ZAV, ZCV, ZCW, ZDA, ZP2, 4NB, 5DF, 610, 2VH, 465, 6UK, 5DL, 6NR
Reply With Quote
  #19  
Old 06-14-2012, 07:18 AM
DreamCar's Avatar
DreamCar DreamCar is offline
Moderator
Location: Planet Earth
 
Join Date: Sep 2010
Posts: 2,445
Mein Auto: F10 M5
-
Reply With Quote
  #20  
Old 06-14-2012, 04:11 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,710
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by JEG23 View Post
@shawnsheridan,

Did you check this value quoted earlier by Miotoo ? In my car it is set to verbaut.

JEG23
No, not specifically. As I previously wrote, 2VB is standard equipment in the US. Thus 2VB should be on the VO, and in turn CAF / 3000 / IcmKod_B_SA2VB should by default be set to verbaut (installed).

I would also think if this was turned off, TPMS would not work at all as opposed to working, albeit without PSI and Temp.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #21  
Old 06-20-2012, 12:38 PM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 233
Mein Auto: 535i GT
Quote:
Originally Posted by miotoo View Post
Did everybody check this value in ICM ? 2VB is the SA code for Tire Pressure Monitor.
On a lark I changed this to nikt today at lunch to see if it would make a difference. I'm still not getting temp or pressure numbers. I do get the green highlites on the tires but I don't get the TMP Active text at the bottom of the display.

I'll go turn it on later today and see if it rests anything.

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.
Reply With Quote
  #22  
Old 06-22-2012, 08:09 AM
chinese_food chinese_food is offline
Registered User
Location: Michigan
 
Join Date: Jun 2012
Posts: 11
Mein Auto: F10
Model:528i
Build Date: july 2011
Delivery Date: september 2011
Status: Working
Did you ever change the wheels and/or tires: no
TPMS Type:?
Tires: 275/55R17
Air/Nitrogen/Other: Nitrogen
Reply With Quote
  #23  
Old 06-08-2012, 01:23 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,710
Mein Auto: 2011 535i M-Sport
2VB is standard equipment in the U.S.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips

Last edited by shawnsheridan; 06-08-2012 at 01:25 PM.
Reply With Quote
  #24  
Old 06-13-2012, 08:29 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is offline
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 10,710
Mein Auto: 2011 535i M-Sport
I know this is a long shot, but I am going to ask anyway. For those without working TPMS, is your car also equipped with Active Steering?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #25  
Old 06-14-2012, 06:34 AM
dmunz dmunz is offline
Officially Welcomed to the 'Fest
Location: Houston
 
Join Date: Apr 2012
Posts: 233
Mein Auto: 535i GT
Quote:
Originally Posted by shawnsheridan View Post
I know this is a long shot, but I am going to ask anyway. For those without working TPMS, is your car also equipped with Active Steering?
No active steering on my F07 either.

FWIW
DLM
__________________
"...hovering like a fly waiting for a windshield on the freeway..." p.g.

Last edited by dmunz; 06-14-2012 at 06:34 AM. Reason: sp
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:23 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms