Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Car Navigation, Audio & Electronics sponsored by BimmerTech

Car Navigation, Audio & Electronics sponsored by BimmerTech
BMW navigation, audio upgrades, XM Radio, Sirius, Bluetooth, and Radar Detector discussions here!

Sponsored by BimmerTech

Reply
 
Thread Tools Display Modes
  #1  
Old 08-27-2012, 04:55 PM
Luchy72 Luchy72 is offline
Registered User
Location: Portsmouth, NH
 
Join Date: Jun 2010
Posts: 1
Mein Auto: 2004 BMW Z4
2004 Z4 - Radio stays on with key removed

Please help!

Recently I took my Z4 in to a local independent mechanic that I have a good history with, to get a few things fixed (door lock issues, roof motor replacement). They fixed the roof fine and fixed part of the problem with the lock (actuator) but didn't fix another part of the problem (General Module). I told them for the $800 they wanted to replace the general module I'd rather just continue using the key. Yeah I know there's a guy in CA who fixes 'em.

When I got my car back, right away I noticed an issue with the radio (Business CD)...when I turn the car on, the radio is off, even if it was on when I turned the car off. I thought this a minor bother and asked them to please put back whatever setting they changed. They wanted another look at the General Module anyway so they said they'd take a look at it but they didn't change any settings.

When I picked my car up the second time, they had no answer about the radio. However right away I discovered a NEW glitch...now the radio doesn't turn off with the key. As in, I can turn the car off and remove the key and the radio still plays. I have to manually turn it off every time I get out of the car or else it would kill the battery. Also, the power randomly turns off sometimes, unrelated to bumps or anything like that. I brought it back *again* and all they could say is "We looked it up and it appears that that model radio just goes bad, it's a common problem. You need a new radio." I replied "This radio ran without a glitch since 2004, and it just happened to 'go bad' on the afternoon you were messing with my electrical system?" and they just shrug. Needless to say I'm not trusting them with my car anymore.

Any ideas what it could be? I just tried disconnecting the negative terminal of the battery to 'reboot' it but that didn't help. Could they have just plugged something in wrong somewhere, or does it need to be reprogrammed or something? HEELLLLPPPPPP!!!!!!
Reply With Quote
Ads by Google
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > Car Navigation, Audio & Electronics sponsored by BimmerTech
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms