Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming

BMW Coding and Programming
Discuss coding options and features on your BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2012, 10:30 AM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
HUD Turn Signals

I am trying to activate the HUD turn signal in my 2013 535ix.

1. HU_NET / HUD_TURNSIGNAL = aktiv
2. KOMBI/BLINKER_HUD_ENABLE = aktiv

There is no checkbox that shows up in the HUD settings. I have also found that the HUD_TURNSIGNAL is not in the 3000 HMI section as shown in the cheat sheet, but is in the 3001 EXBOX section on my car. Any ideas from the gurus?
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
Advertisement
  #2  
Old 09-13-2012, 11:12 AM
bmguy bmguy is offline
Officially Welcomed to the 'Fest
Location: Alberta
 
Join Date: Nov 2011
Posts: 318
Mein Auto: 2012 Dinan 550xi
When I enabled it; you had to click on "display options" first, then it gave you alist of itmees you can check, and uncheck; the "display Options" (maybe exact text is different) looks like a title for that menu, but when you select it, it brings up a bunch of things you can show or hide on the HUD, turn signals will appear in that list if you did everything right
Reply With Quote
  #3  
Old 09-13-2012, 07:53 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by bmguy View Post
When I enabled it; you had to click on "display options" first, then it gave you alist of itmees you can check, and uncheck; the "display Options" (maybe exact text is different) looks like a title for that menu, but when you select it, it brings up a bunch of things you can show or hide on the HUD, turn signals will appear in that list if you did everything right
Is your car a 2013 with the new HU_NBT, and can you confirm that your HUD Turn Signals are working?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #4  
Old 09-13-2012, 07:55 PM
bmguy bmguy is offline
Officially Welcomed to the 'Fest
Location: Alberta
 
Join Date: Nov 2011
Posts: 318
Mein Auto: 2012 Dinan 550xi
No Sorry - I'm a 2012 Nov15/2012 build...
Reply With Quote
  #5  
Old 09-13-2012, 08:02 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by bmguy View Post
No Sorry - I'm a 2012 Nov15/2012 build...
Ok. We need someone else with the new HU_NBT to see what is going on.

Paging @falcongeek ...
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #6  
Old 09-13-2012, 08:10 PM
falcongeek falcongeek is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Aug 2012
Posts: 17
Mein Auto: 2013 535i
Quote:
Originally Posted by shawnsheridan View Post
Ok. We need someone else with the new HU_NBT to see what is going on.

Paging @falcongeek ...
I did try coding the HUD turn signals when I first started coding and was not able to get them working either. I set both KOMBI BLINKER_HUD_ENABLE and HU_NBT HUD_TURNSIGNAL as aktiv and also did not get a checkbox to show in the iDrive HUD settings.

I did some digging a while ago and couldn't find any additional settings that I though needed to be changed, but it is possible that I missed something.

Adam
Reply With Quote
  #7  
Old 09-13-2012, 11:59 AM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
The checkbox on the HUD display options is not coming up with the turn signal checkbox. I have checked the coding multiple times and it shows in the HU_NET and KOMBI that they are aktiv.
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #8  
Old 09-13-2012, 01:40 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Ionic202 View Post
The checkbox on the HUD display options is not coming up with the turn signal checkbox. I have checked the coding multiple times and it shows in the HU_NET and KOMBI that they are aktiv.
What are the CAFD File names for your HU_NBT and Kombi ECU's?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #9  
Old 09-13-2012, 02:56 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
what are the cafd file names for your hu_nbt and kombi ecu's?
hud_nbt - cafd_00000ded_001_019_008
kombi - cafd_00000069_009_000_042
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner

Last edited by Ionic202; 09-13-2012 at 04:46 PM.
Reply With Quote
  #10  
Old 09-13-2012, 02:02 PM
AutobahnCowboy AutobahnCowboy is offline
Registered User
Location: Germany
 
Join Date: Sep 2012
Posts: 35
Mein Auto: BMW
ive set today the KOMBI/BLINKER_HUD_ENABLE to aktiv but not the second one.
id no access to internet while coding so i could only watch some pdf´s i got

currently ive the checkbox for "Blinker" in settings but no Blinker in HUD while driving around

i try to set the other option to aktiv too and will report
Reply With Quote
  #11  
Old 09-13-2012, 07:17 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Well, it could be different in 2013, but I highly doubt it. Just to make triple sure though, please check the following:

1) Code KOMBI / BLINKER_HUD_ENABLE = aktiv - This actually enables the feature.
2) Code HU_NBT / HUD_TURNSIGNAL = aktiv - This adds the iDrive Checkbox to toggle the feature on and off.
3) Go into iDrive HUD Settings, and enable checkbox for Hud Turn Signals as shown in attached picture.
Attached Thumbnails
Click image for larger version

Name:	vHXaf9.jpg
Views:	441
Size:	328.4 KB
ID:	341751  
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #12  
Old 09-13-2012, 07:45 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
Well, it could be different in 2013, but I highly doubt it. Just to make triple sure though, please check the following:

1) Code KOMBI / BLINKER_HUD_ENABLE = aktiv - This actually enables the feature.
2) Code HU_NBT / HUD_TURNSIGNAL = aktiv - This adds the iDrive Checkbox to toggle the feature on and off.
3) Go into iDrive HUD Settings, and enable checkbox for Hud Turn Signals as shown in attached picture.
1) yes
2) yes
3) no check box on settings screen.
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #13  
Old 09-13-2012, 07:55 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by Ionic202 View Post
1) yes
2) yes
3) no check box on settings screen.
What options are shown on your HUD Settings Screen? Can you post a picture of it?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #14  
Old 09-13-2012, 08:16 PM
Ionic202 Ionic202 is offline
Registered User
Location: CO
 
Join Date: Aug 2012
Posts: 40
Mein Auto: 2013 535i xDrive
Quote:
Originally Posted by shawnsheridan View Post
What options are shown on your HUD Settings Screen? Can you post a picture of it?
It is the same as prior to coding.......
Attached Thumbnails
Click image for larger version

Name:	IMG_0295 (Small).JPG
Views:	435
Size:	86.5 KB
ID:	341756  
__________________

2013 535i xDrive, Imperial Blue Metallic, Oyster and Black Nappa Leather, ZCW, ZDA, ZDH, ZLS, ZMP, ZPP, ZTP, 2TB, 323, 416, 4CE, 4U1, 5AC, 677, JB4 Tuner
Reply With Quote
  #15  
Old 09-17-2012, 12:19 PM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Hey guys, I had the same issue with my 2013 535i as well. I figured it out eventually. You need to set one of the PIA options to aktiv (I don't remember the name). I will post it here once I get home.

Last edited by digital; 09-17-2012 at 12:20 PM.
Reply With Quote
  #16  
Old 09-17-2012, 12:24 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by digital View Post
Hey guys, I had the same issue with my 2013 535i as well. I figured it out eventually. You need to set one of the PIA options to aktiv (I don't remember the name). I will post it here once I get home.
This will be good to know, although I hope it does not turn out to be a PIA setting that exists in F30 only and not F10 like this one:

Pia_Default_Tippblinken

http://www.bimmerfest.com/forums/sho...182&highlight=
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #17  
Old 09-17-2012, 12:26 PM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Mine is F10 2013 with the new Nav. I'll keep you posted.
Reply With Quote
  #18  
Old 09-17-2012, 12:30 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by digital View Post
Mine is F10 2013 with the new Nav. I'll keep you posted.
Good deal. Thanks.
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #19  
Old 09-17-2012, 06:24 PM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Here it is:

1- Code KOMBI / HUD_PIA_BLINKER = aktiv
2- Code KOMBI / BLINKER_HUD_ENABLE = aktiv
3- Code HU_NBT / HUD_TURNSIGNAL = aktiv

The iDrive check box will not show up, but it works. (I couldn't figure out the check box issue)
__________________
2013 535i xDrive M-Sport Graphite
2011 X3 35i White
2004 325i Silver Grey
1978 518
Reply With Quote
  #20  
Old 09-17-2012, 06:26 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by digital View Post
Here it is:

1- Code KOMBI / HUD_PIA_BLINKER = aktiv
2- Code KOMBI / BLINKER_HUD_ENABLE = aktiv
3- Code HU_NBT / HUD_TURNSIGNAL = aktiv

The iDrive check box will not show up, but it works. (I couldn't figure out the check box issue)
Sweet! Maybe you can kind the missing Pia_Default_Tippblinken or equivalent too?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #21  
Old 09-17-2012, 07:12 PM
digital digital is offline
Registered User
Location: Toronto, ON
 
Join Date: Jan 2008
Posts: 5
Mein Auto: 2013 535i xDrive M-Sport
Quote:
Originally Posted by shawnsheridan View Post
Sweet! Maybe you can kind the missing Pia_Default_Tippblinken or equivalent too?
I'll work on it
__________________
2013 535i xDrive M-Sport Graphite
2011 X3 35i White
2004 325i Silver Grey
1978 518
Reply With Quote
  #22  
Old 09-21-2012, 08:19 PM
falcongeek falcongeek is offline
Registered User
Location: Fort Worth, TX
 
Join Date: Aug 2012
Posts: 17
Mein Auto: 2013 535i
Quote:
Originally Posted by digital View Post
Here it is:

1- Code KOMBI / HUD_PIA_BLINKER = aktiv
2- Code KOMBI / BLINKER_HUD_ENABLE = aktiv
3- Code HU_NBT / HUD_TURNSIGNAL = aktiv

The iDrive check box will not show up, but it works. (I couldn't figure out the check box issue)
I was able to get the HUD Turnsignals working on my 2013 F10 also using the KOMBI / HUD_PIA_BLINKER = aktiv setting. I also found that they continue to work even with HU_NBT / HUD_TURNSIGNAL = inaktiv. It looks like the checkbox function maybe similar to the Entertainment/Telephone List where the checkbox just won't work but the HUD still displays them properly?

Adam
Reply With Quote
  #23  
Old 09-21-2012, 08:39 PM
shawnsheridan's Avatar
shawnsheridan shawnsheridan is online now
Officially Welcomed to the 'Fest
Location: Houston, TX
 
Join Date: Jan 2009
Posts: 12,947
Mein Auto: 2011 535i M-Sport
Quote:
Originally Posted by falcongeek View Post
I was able to get the HUD Turnsignals working on my 2013 F10 also using the KOMBI / HUD_PIA_BLINKER = aktiv setting. I also found that they continue to work even with HU_NBT / HUD_TURNSIGNAL = inaktiv. It looks like the checkbox function maybe similar to the Entertainment/Telephone List where the checkbox just won't work but the HUD still displays them properly?

Adam
Your check box shows up though, its just nonfunctional?
__________________

- 2011 535i M-Sport (Born 10/10) - AW/BLK/DW - /ZMP (w/ARS, EDC, DHP, & AD) /ZPP /ZP2 (w/ZPS & ZPT) /ZCV (w/SCAD) /6FL /6VC
- Mods - M5 343M 20" Forged Wheels / 6WB MFID / 2TB SAT / 4U1 Ceramic / 6NR Apps / PDV 5k Fogs / Rear Fogs / Euro Tail Lights / Cyba Quad Tips
Reply With Quote
  #24  
Old 10-03-2012, 04:49 PM
wdimagineer's Avatar
wdimagineer wdimagineer is offline
Officially Welcomed to the 'Fest
Location: San Francisco, CA
 
Join Date: Dec 2011
Posts: 671
Mein Auto: 2013 M5
Quote:
Originally Posted by falcongeek View Post
I was able to get the HUD Turnsignals working on my 2013 F10 also using the KOMBI / HUD_PIA_BLINKER = aktiv setting. I also found that they continue to work even with HU_NBT / HUD_TURNSIGNAL = inaktiv. It looks like the checkbox function maybe similar to the Entertainment/Telephone List where the checkbox just won't work but the HUD still displays them properly?

Adam
Interesting. Do you get a checkbox? I don't. But they DO work.
__________________
Current: 2014 X5 xDrive50i ZMM - Alpine White/Mocha (Mods In Progress!)
Past: 2014 Jeep SRT - 2013 Tesla Model S P85+ - Bimmerpost Featured 2013 F10 M5 - 2012 550 xDrive - 2011 M3 ZCP
Reply With Quote
  #25  
Old 10-03-2012, 05:16 PM
FrogmanF30's Avatar
FrogmanF30 FrogmanF30 is offline
Officially Welcomed to the 'Fest
Location: Southern California
 
Join Date: Mar 2012
Posts: 432
Mein Auto: 2012 328i
Quote:
Originally Posted by wdimagineer View Post
Interesting. Do you get a checkbox? I don't. But they DO work.
On my F30 (with CIC not NBT) I get the checkbox and it's enabled (I can check and uncheck it), but no turn signals show up in the HUD when checked.

Did you only change the KOMBI / HUD_PIA_BLINKER = aktiv and nothing else to get yours to work? I have not tried that yet. I've also always set HUD_BLINKER_ENABLE to aktiv too.

When I just reset HU_CIC / 3000 / HUD_TURNSIGNAL back to inaktiv (leaving the other 2 changes intact), the check box goes away and no signals in the HUD.

I think the HU_CIC change just enables the checkbox on the screen and the KOMBI change(s) actually enable the function.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > The Best of Bimmerfest! > BMW Coding and Programming
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 09:55 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms