Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)

E39 (1997 - 2003)
The BMW 5-Series (E39 chassis) was introduced in the United States as a 1997 model year car and lasted until the 2004 when the E60 chassis was released. The United States saw several variations including the 525i, 528i, 530i and 540i. -- View the E39 Wiki

Reply
 
Thread Tools Display Modes
  #1  
Old 09-27-2012, 11:42 AM
natgreen natgreen is offline
Registered User
Location: Burke
 
Join Date: Sep 2012
Posts: 1
Mein Auto: 1996 BMW 528i
1996 E39 528 Left Front Noise after brake job

Completed changing the Front Brakes, Rotors, and Pad on my 1996 E39 528I BMW. My fist time attemting to do such. Upon completion of the job, I noticed a noise (grinding) coming from the front left driver side. Took off the wheel, re-check my work, drove the car again....same noise. I am trying to figure what I did wrong.
Reply With Quote
Ads by Google
  #2  
Old 09-27-2012, 04:19 PM
AndrewZ's Avatar
AndrewZ AndrewZ is offline
Ones and Zeros
Location: In Between Dreams
 
Join Date: Feb 2006
Posts: 10,982
Mein Auto: It has two dipsticks
Welcome to bimmerfest
Reply With Quote
  #3  
Old 09-27-2012, 04:38 PM
anton831 anton831 is offline
Registered User
Location: KY
 
Join Date: Mar 2012
Posts: 31
Mein Auto: 528i
is your abs sensor installed right
Reply With Quote
  #4  
Old 09-27-2012, 06:21 PM
black528i black528i is offline
Registered User
Location: Lincoln, NE
 
Join Date: Jan 2012
Posts: 68
Mein Auto: 97 528i
Have you tried this ... http://zeckhausen. com/bedding_in_brakes.htm?
Reply With Quote
  #5  
Old 09-28-2012, 03:43 PM
Mikes530 Mikes530 is offline
Officially Welcomed to the 'Fest
Location: Toronto
 
Join Date: Mar 2011
Posts: 286
Mein Auto: 530
Sounds as if something (maybe the splash shield) might been bent or mis-aligned and is contacting the rotor. Your best approach would be to get the wheel off again and manually spin the rotor to catch the noise. If no noise repeat the process with the wheel on and properly torqued. Make sure you support the car properly on stands.
Good luck
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 5 Series > E39 (1997 - 2003)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 01:55 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms