Welcome to Bimmerfest -- The #1 Online Community for BMW related information! Please enjoy the discussion forums below and share your experiences with the 200,000 current, new and past BMW owners. The forums are broken out by car model and into other special interest sections such as BMW European Delivery and a special forum to voice your questions to the many BMW dealers on the site to assist our members!

Please follow the links below to help get you started!

Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)

7 Series - E65 / E66 (2002 - 2008)
Discussion pertaining to the flagship BMW here.

Reply
 
Thread Tools Display Modes
  #1  
Old 10-05-2012, 10:48 AM
silver745li silver745li is offline
Registered User
Location: usa
 
Join Date: Apr 2012
Posts: 20
Mein Auto: bmw
Unhappy cluster light is not working

need help....2004 745LI .It's been for 4 days my cluster lights is not working. last night tried to disconnect the battery for over night,and then cluster lights started working again but only for 30 minutes.....pleaseeee help.( i checked the speedometer pull of and check all are good.I have already changed the module control under trunk. need help guys:
Reply With Quote
Advertisement
  #2  
Old 10-05-2012, 12:44 PM
silver745li silver745li is offline
Registered User
Location: usa
 
Join Date: Apr 2012
Posts: 20
Mein Auto: bmw
No body!??????
Reply With Quote
  #3  
Old 10-05-2012, 05:32 PM
SFbay SFbay is offline
Account Under Review
Location: SF
 
Join Date: Mar 2012
Posts: 893
Mein Auto: BMW 745i
Quote:
Originally Posted by silver745li View Post
No body!??????
Ok here it is:
There is a fuse for that in the glovebox, check all of them
I don't remember what number it is or it's name, it's been 2 yrs ago
Reply With Quote
  #4  
Old 10-05-2012, 07:50 PM
silver745li silver745li is offline
Registered User
Location: usa
 
Join Date: Apr 2012
Posts: 20
Mein Auto: bmw
I check the fuse no.28,33 clean and cluster lights working fine.when I'm driving the lights just out again.on fuses diagram Show fuse NO33 is 7,5 amperes and my only 5 amperes.and now my service engines is on.
Reply With Quote
Reply

Bookmarks


Forum Navigation
Go Back   Bimmerfest - BMW Forums > BMW Model Discussions > 7 Series / 8 Series > 7 Series - E65 / E66 (2002 - 2008)
Today's Posts Search
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



Forum Jump


All times are GMT -7. The time now is 08:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
© 2001-2011 performanceIX, Inc. All Rights Reserved .: guidelines .:. privacy .:. terms